LMD18201T Como usar no Arduíno

Olá tenho disponível varias unidades do LMD18201t, mas não consigo fazer esse bendito funcionar com o Arduíno, alguém já fez? tem algum circuito pronto? Não sei mais o que fazer.. grato

Como e que o ligaste?

Achas que somos adivinhos?

Adivinho não, apenas orientando.. Com um esquema de alguém que já fez.. É beeeeem mais fácil mostrar um esquema.. Eu fiz como no datasheet, porém nas entradas pwm liguei no pwm do arduino.. E eu liguei com jumpers, motor dc, e arduino. Você tem alguma ideia? Obrigado des de já. ;D

como estas a alimentar o motor?

bubulindo:
como estas a alimentar o motor?

Alimentei com 12v conforme necessidade do motor…
mas o lmd alimentei com 5v…

Mais uma vez… Sem esquema ou código…

É uma coisa olhar para o que está feito e dizer o que está ou pode estar mal.

É outra fazer o trabalho por ti…

Como podes ler por todo este fórum, as pessoas estão aqui para ajudar e não para trabalhar para ti.

não pedi pra trabalhar pra mim.. o esquema é justamente o que eu quero.. usei o do datasheet e ão funcionou..

|500x314 no pino 6 liguei em 12v.. pino 4 - 0v pino 3 em 5v pino 5 no pwm arduino..

void loop() {
  
int val=analogRead(0);
  val = map(val, 0, 1023, 0, 255);
analogWrite(9,val);
}

código só isso..

O gnd dos 5v está ligado no gnd dos 12V?

Se leres o datasheet, eles mencionam que o pino 7 é para o gnd da alimentação dos motores e o pino 8 é para a alimentação do circuito lógico.

Talvez separar esses dois pinos com os grounds diferentes seja o que está a faltar.

Nota também que podes ter queimado o chip, ou o circuito lógico dependendo da diferença entre os 5V e os 12V... Mas suponho que saibas isso.

bubulindo: O gnd dos 5v está ligado no gnd dos 12V?

Se leres o datasheet, eles mencionam que o pino 7 é para o gnd da alimentação dos motores e o pino 8 é para a alimentação do circuito lógico.

Talvez separar esses dois pinos com os grounds diferentes seja o que está a faltar.

Nota também que podes ter queimado o chip, ou o circuito lógico dependendo da diferença entre os 5V e os 12V... Mas suponho que saibas isso.

Usei o GND junto.. não chegou a ligar, aquecer ou algo parecido. vou fazer essa mudança do gnd.. Obrigado

Depois diz se funcionou...

Esse chip e bastante interessante para controlo de motores e da maneira que colocaste, a unica coisa que me parece que possa dar problemas e mesmo o GND nao ser o mesmo das tensoes 5V e 12V. Nao sera de todo pior medir qual e essa diferenca antes de ligar... So por causa das coisas.