LMV358 and Atmega328P HOT

Hello everyone,

I'm kinda new in Arduino. Today I was trying to turn on my stepper motor with L293D, but I accidentally shorted something in Arduino back. Since then I wasn't able to upload code to it, but PC recognize Arduino, after a few seconds LMV358 get's really hot and after a while Atmega328P too. Any advice would be cool. =(

Get another one, you've damaged something pretty badly. You can try changing just the '328P, but if parts like the '358, which is just a voltage comparator, are hot, you've done more than damage the '328P.

Thanks for advice, tomorrow I will post results after changing 328P. :) By the way, how could I check 328P without changing it?

Pull it out, try the Loopback Test. If that passes, try uploading a simple sketch, like Blink.

It passed test, a data was echoed. But then I tried to upload blink sketch I got this avrdude: stk500_getsync(): not in sync: resp=0x30.

Try re-uploading the bootloader then.

Damn, I don't have a programmer to do it. :/

You just have the one board? That makes debugging tough.

Yeah, maybe a multimeter could help?

Is it possible that my voltage regulator(NCP1117ST50T3G ) is broken? Could it cause such a things?

Maybe - is it outputting more than 5V? That would damage the '328P.

I measured its voltages:

Between NCP1117ST50T3G pins: 1-3 - 3.80V 2-3 - 4.40V 1-2 - 0.53V

Max 4.40V, maybe its not 5V because there is a short circuit somewhere?

Ok, I found that LMV358 IN1 get's way too much voltage (1.8V, instead of absolute maximum 0.5V), but other Input (IN2) gets 0.2V. Then I tried to measure IN1 voltage all LED's faded out a bit.

Measure the 3 pins with respect to GND.
Pin 1 is Gnd, 2 is output, 3 is input.

If you don’t have > ~6.5V on pin 3, it can’t regulate pin 2 to be 5V.
If you do have sufficient input, what is dragging the output down?
If it rises to 5V with '328P removed, that’s a pretty good sign.
If still low with '328P removed, something else is bad - like the LMV358 that you mentioned.

lm1117-n.pdf (2.45 MB)

Ok, I measured pins again without 328P and I found that voltage increased between all pins to nearly 5V.

Sounds like a fried part then. Are you in the US? http://www.dipmicro.com/store/CPU-ARD328P-DUE https://www.sparkfun.com/products/10524 http://www.nkcelectronics.com/arduino-uno-ready-avr-atmega328p-microcontrol328.html http://www.adafruit.com/products/123

I'm living in Lithuania(North-East Europe) so this is a little problem for me. Local shop sells Atmega328, but without bootloader. :~

Try "contact us" at dipmicro.com, see if they will put some in USPS mail to you.

No response from them. :roll_eyes:

Have some patience. Much more than 6 minutes worth!