LMV358 and Atmega328P HOT

They replied that they should ask manager to make an exception for shipping. But it's likely that this will cost a little more than 2 atmega328p chips. :D By the way, Arduino passed loopback test, doesn't it mean that atmega328p is not broken?

No, loopback just means the USB/Serial adapter chip is working. If the 328P is hot to the touch when powered up, that usually indicates one or more outputs are damaged and complete chip failure is imminent, or has already occurred.

Once you get a working board, you can use that to program future chips for standalone designs. See "program bootloader" http://www.gammon.com.au/forum/index.php?bbtopic_id=123

I tried to connect 5V to 328P on breadboard directly and connected LED on PIN9, as I remember last code which was uploaded into Atmega used this pin to turn on stepper. LED turned on, but then I tried to connect to PIN8 LED faded out, but Atmega works cold now. By the way I forgot to mention that L LED always is turned on even if I pop out 328P. And I thought why does LMV358 gets hot even then 328P is not plugged in. Then I'm trying to upload sketch to Arduino RX led blinks.

L LED is driven by voltage comparator output With no input from '328P, the input will float high its output will then go high, turning on the LED. If the LVM358 is hot it is likely damaged as well.

So there is a possibility that if I will change my LMV358 chip it could work?

Yes. Surface mount, be careful not to damage the pads & traces.

Thanks man, I will try to change it. You helped me a lot at learning everything about this. :)

OK, good luck.

You do have a 330 or higher value resistor in series with the LED right?

There is resistor, because it is on Arduino board.

Ok, I got LMV358 and Atmega328P-PU without bootloader, i plugged in both and they didn't got even warm after about hour of activity, but now then I tried to upload sketch I got this error again:

avrdude: stk500_getsync(): not in sync: resp=0x00

You need to burn a bootloader to your unprogrammed chip. Tools....burn bootloader.. in the ide.