Loading programs to the Arduino

I should start by telling you i got an Arduino.org product, I don't know if there are any differences in installation, but my problem is as follows; as i downloaded the IDE program from the .org site (1.7.10) it went over driver installation, the booklet says that should have happened later, after connecting to the board. In any case, when i check the device it says it has all the required drivers, but i can't load the blink program on it. I am on Windows 10.....any help would be appreciated.

rh-duino

rhduino:
i can’t load the blink program on it.

That’s nowhere near enough information. Please provide the FULL text of any error output you’re seeing in the black console window at the bottom of the Arduino IDE window. I haven’t used the .org IDE but in the .cc IDE you will see a button on the right side of the orange bar after there is an error “Copy error message”. Click that button and paste the error in a message here USING CODE TAGS(</> button on the toolbar). If you can’t do that then just select the entire error output(you will probably have to scroll up to see the whole thing) from the console window, copy, and paste.

Here is the error as it comes from the "copy error messages" option in the program;

Arduino: 1.7.10 (Windows 8.1), Board: "Arduino Uno"

Sketch uses 1,030 bytes (3%) of program storage space. Maximum is 32,256 bytes.

Global variables use 9 bytes (0%) of dynamic memory, leaving 2,039 bytes for local variables. Maximum is 2,048 bytes.

avrdude: ser_open(): can't open device "\.\COM1": The system cannot find the file specified.

Problem uploading to board. See http://www.arduino.cc/en/Guide/Troubleshooting#upload for suggestions.

This report would have more information with "Show verbose output during compilation" enabled in File > Preferences.

You can try asking in the arduino.org forum. That IDE is not the same as the arduino.cc IDE.

pert: USING CODE TAGS

Sigh... I've started putting it in bold and red and they still ignore.

Are you sure you have the right COM port selected? Try this:

  • With the Arduino board unplugged from the USB open the Tools > Port menu and note the listed ports. If the Port menu is gray and disabled then that means there are no ports available.
  • Close the Tools > Port menu.
  • Plug in the USB cable on the Arduino board
  • Wait a little while for the Arduino board to connect
  • Open Tools > Port, the new port on the list is your Arduino board. In some cases it will have the name of the board next to the port name but this doesn't happen with all boards. If the Port menu is gray and disabled then that means your Arduino board didn't install correctly. You may need to install a driver.
  • Select your Arduino's port from the menu.

Sigh... I've started putting it in bold and red and they still ignore.

Not enough, Sir.

It should have been in Braille and vibrating :)

Pert, my apologies for not following the instructions correctly, the problem on my end is ignorance I must admit. I don't know how to use the code tags, otherwise I would have done it. I tried what you suggested and COM3 shows up when I plug it in, now when I try to upload "blink" it is doing it, THANK YOU very much, i appreciate you following up on the initial post. Have a great day.

BTW, i did try the arduino.org forum......may post has not even been opened yet much less replied to.

Thanks again

rhduino:
BTW, i did try the arduino.org forum…may post has not even been opened yet much less replied to.

.cc to the rescue! If you are able to use the .cc IDE you’ll be more likely to get help here because, like me, many of the people on this forum don’t have any experience with the .org IDE or hardware. I always try to help when I can regardless.