LOL, great bug in 1.6.x with Maximized/Minimized

Open properties and choose Run Maximized (instead of Normal default). Enjoy!!! :slight_smile:
I hope it will be fixed in 1.6.2.

PS: To be more specific - IDE not obeys this option, obeys splash instead.

Which OS are you using?

WinXP, I doubt that on Win7/8 this behavoir will change. I have 1.5.2 version on Win7 with same issue.

I have windows 7 and I can't find Run Maximized. Can you give an hint?

:smiley: Just rightclick on Arduino IDE shotcut, choose Properties and you'll see it at Run field. This is Windows' startup option. Default is Normal window but we can choose Maximized or Minimized too. I'd like to start with maximized editor but I failed 'coz IDE handles it improperly - it maximizes splash screen!

Can you please open an issue on github? Issues ยท arduino/Arduino ยท GitHub
This way we can track the problem

ok, done.

Bug nealry remains in 1.6.3. Splash screen now not maximized but IDE still not obey startup option. I told about MAXIMIZED, but MINIMZED has same problem. IDE just ignores this setting. Bad behavior!