Long distance USB gets no data from ARDUINO UNO

Hoi friends,
i have a 5 m active USB-cable with integrated circuit, connected to this is an non-active hub with a cam and a ThermoHID-USB Temp reader.
All works fine so far.

now i connected the arduino uno with a dht11 sensor (which works fine directly connected to the pc) to the hub - the port is remembered as the Arduino UNO and appears also in the hardwaremanager (vista).

Even if i connect the ARDUINO directly to an ACTIVE USB-Hub the same !

BUT: no datas are transferred any longer :astonished:
The settings are 9600, 8, none, one.

The RDUINO is only with the USB-Cable conneted to the Hub, no own power supply.

Does anyone know a solution ?

Do you mean a "powered" hub when you say "active" hub ?
Could you measure the voltage of the Arduino ?
If the powered hub is a USB 1.1 hub, it probably won't work.
Or a cable could be bad. Do you use good quality usb cables ?

Hoi,

yes - active = powered.

It is a 1.1 hub (and old one i found in my "waste"-box) and he cables are good (tried several).
Yet it seems i solved the problem by changing the baud-rate from 9600 to 4800.

Time plays no role in this environment, so it works so far.

Get a USB 2.0 powered hub.