Lost COM port

Hey guys!

I recently got an Arduino Uno, and have been thoroughly enjoying it. I have the software installed on a win7 computer, and a winxp computer. However I recently lost the COM port where the Arduino was connected (COM3). I can't pinpoint what may have caused it, but I had made a temperature monitor with it, and I was monitoring the output via the Serial Monitor. I left it running overnight, it was OK and running in the morning, then at some point the arduino software probably crashed, as I the windows have closed, but I hadn't gotten an error message. I tried reinstalling drivers, and reseting the board, but the COM port does not show up in the serial port list (i.e. says "COM3 could not be found" when trying to upload")

The board does work fine on my other computer, I managed to upload the blink example again.

Any ideas, on how I may diagnose/fix this?


Have you tried rebooting the computer?

Yes, I did, and the issue was resolved.

Just realized I hadn't done it, after I posted, sorry about that. :blush:

No need to apologize. The symptom is very likely the result of a problem in the Windows kernel. I've had similar symptoms occur. In my case, closing all applications that have accessed the serial port (Task Manager may be necessary to close any that have disappeared) then disconnecting and reconnecting the board has always resolved the situation.