lto-wrapper failed

Arduino web editor will not verify example code such as Bare minimum and blink. Error message is lto-wrapper failed

./opt/arduino-builder/arduino-builder -compile -core-api-version 10611 -hardware opt/arduino-builder/hardware -hardware ./opt/cores -tools opt/arduino-builder/tools -tools ./opt/tools -built-in-libraries opt/libraries/latest -logger humantags -fqbn arduino:avr:uno -build-cache /tmp -build-path /tmp/790306953/build -verbose -prefs runtime.tools.avr-gcc.path=./opt/tools/avr-gcc/5.4.0-atmel3.6.1-arduino2 -prefs runtime.tools.avrdude.path=./opt/tools/avrdude/6.3.0-arduino14 -prefs runtime.tools.arduinoOTA.path=./opt/tools/arduinoOTA/1.2.1 -libraries /tmp/790306953/custom -libraries /tmp/790306953/pinned /tmp/790306953/BareMinimum

Linking everything together...

lto1: fatal error: bytecode stream generated with LTO version 3.0 instead of the expected 4.1

compilation terminated.

lto-wrapper: fatal error: ./opt/tools/avr-gcc/5.4.0-atmel3.6.1-arduino2/bin/avr-gcc returned 1 exit status

compilation terminated.

/home/ubuntu/opt/tools/avr-gcc/5.4.0-atmel3.6.1-arduino2/bin/../lib/gcc/avr/5.4.0/../../../../avr/bin/ld: error: lto-wrapper failed

collect2: error: ld returned 1 exit status

exit status 1

I'm getting this too, only as of today.

It works for Arduino/Genuino 101, but not Uno, for example.

Argh! I'm supposed to be showing some students this editor tomorrow and now I'm getting this error!

I have the same issue, as of today. :(

ditto

I have this too since a couple of hours

Oh, thank goodness! I’ve been struggling with this for a while not knowing it wasn’t just me! I’ll try copying code to the local desktop app. :slight_smile: >:(

This was working yesterday but not today. Exactly the same error as shown above.

Using Win 10 home edition (current version) Chrome browser (current version)

MSI Laptop

Cheers

I copied and pasted the code into the desktop app which worked.

There are multiple other reports of this bug:

I recommend subscribing to those threads so that you'll be sure to get news of any progress in fixing it.

This is an Arduino Web Editor specific problem so the workaround is to use the regular Arduino IDE, which you can download for free from: http://www.arduino.cc/en/Main/Software

Hello, please follow topic Issue 2018-10-30: lto-wrapper error prevent compilations for further information and updates about this.

Thank you.

Seems to be working now.

Thanks ...