LV-EZ1 ultrasound sensor question

Hi, I am testing the LV-EZ1 sensor. And I use the Advance Example code from the arduino-Maxbotix-master Library.

I am very baffled with the readings. Here are some of the readings from the Analog output: (At the time of testing, the sensor is pointing to an open space without any obstacle and without moving.)

Reading... AD (BEST): 64.77cm - 92ms - [64.77, 64.77, 64.77, 64.77, 64.77, 66.04, 71.12, 95.25, 96.52, 245.11] - Highest Mode: 64.77 - Lowest Mode: 64.77 - Median: 66.04 - Best: 64.77

Reading... AD (BEST): 57.15cm - 94ms - [57.15, 57.15, 57.15, 57.15, 57.15, 57.15, 57.15, 58.42, 60.96, 62.23] - Highest Mode: 57.15 - Lowest Mode: 57.15 - Median: 57.15 - Best: 57.15

Reading... AD (BEST): 39.37cm - 92ms - [39.37, 39.37, 39.37, 39.37, 39.37, 39.37, 39.37, 40.64, 44.45, 45.72] - Highest Mode: 39.37 - Lowest Mode: 39.37 - Median: 39.37 - Best: 39.37

In the first reading AD (BEST): 64.77cm - 92ms - [64.77, 64.77, 64.77, 64.77, 64.77, 66.04, 71.12, 95.25, 96.52, 245.11] - Highest Mode: 64.77 - Lowest Mode: 64.77 - Median: 66.04 - Best: 64.77 at first it seems consistent 64.77, after five 64.77 outputs, the reading start to increase then the last reading is 245.11!! Why is that? Is it the ghost reading?

Now even after filtering. the three highest mode readings of the sensor fluctuate from 64.77 to 57.15 to 39.37 (The sensor never moved.)

How do I know which figure is the reliable one?

BTW, I have also tried it with the PM output. I have the same fluctuation result.