Mac + Arduino, serial ports not listed

Hello, I've been toying around with an Arduino for a couple of weeks on my PC with no issues. Tonight I installed the Arduino software on my Mac and plugged it in, but I'm not seeing the Serial Ports under the Tools menu.

  • Mac OS X Lion 10.7.4

  • OSEPP Mega 2560

  • As I said, I've been using it on my PC with no issues.

  • It appears to be recognized in System Report under the USB category

  • It turns on and runs the previous program I uploaded.

  • The only Serial Ports listed are Bluetooth related

Thank you for your assistance!

HI Belmont. The mega2560 should be listed under the serials list in the arduino ide as dev//"ttyusbmodem*d**" Have you looked in your network preferences window? A box should pop up saying "found arduino mega2560" etc...

The OSEPP Mega 2560 uses a FTDI chip for USB to serial conversion. You probably need to install the FTDI drivers that can be downloaded here: http://www.ftdichip.com/Drivers/VCP.htm

[quote author=Louis Davis link=topic=106073.msg795965#msg795965 date=1337172082] The OSEPP Mega 2560 uses a FTDI chip for USB to serial conversion. You probably need to install the FTDI drivers that can be downloaded here: http://www.ftdichip.com/Drivers/VCP.htm [/quote]

That's what I was afraid of, but I thought I recalled seeing something that said there were only a couple of models that used the FTDI drivers. Thanks for the clarification!

Belmont: That's what I was afraid of, but I thought I recalled seeing something that said there were only a couple of models that used the FTDI drivers. Thanks for the clarification!

All OSEPP modules have FTDI chips. In their rush to print deceptive packaging, they neglected to mention this minor difference.

I had this problem. My problem was a bad USB cable...