mac ftdi issue (solved for now)

Issue: while attempting to upload code to a promini on atom/ the board was unable to be found. (this is not the first or a unique situation for me using various chips (looking at you esp8266). Just moments before was able to run many uploads and now, no dice. Arduino IDE does not show the device either.

I have been working on updating some code for an art project that will be shown this coming Saturday and it seemed my ftdi chip broke all of a sudden. Welp... That is an issue that is not solved by buying a new one while the old (stable) code was not on the chips and I can't get a new chip any time soon so I went down a rabbit hole trying to figure out what else could be the issue.

My computer is unfortunately a MacBook Pro (13-inch, 2016, Four Thunderbolt 3 Ports). 2.9 GHz Intel Core i5, 8 GB 2133 MHz LPDDR3, Intel Iris Graphics 550 1536 MB, running macOS Mojave 10.14.4 (there is a lot that is nice about this machine but I have a lot of complaints with it, so many that I very much regret the decision of buying it)

Searching ftdi mac not registering brought up issues with drivers and solutions of restarting and/or downloading the latest driver for ftdi. Tried this it did not work. Youtube suggested I restart the computer while the device was plugged in, this did not work. System report did not show the device in the USB section where it once lived. Updating everything with the OS as well as Atom + did not change a thing.

I unplugged the chip and inspected it to make sure it was not a knock off. Seemed legit. Searched more specifically for issues with this chip, was not finding anything new. I eventually found that my arduino IDE might need to be updated as this one comment in a thread indicated ftdi drivers can be updated through the ide. Seemed like a stretch but I noticed the IDE was 1.8.3 and we have had a few updates, nothing mentioned changes pertaining to this issue though. Updated the ide, plugged in the ftdi chip to the computer, plugged the promini to the ftdi chip, attempted to upload the code through atom and BOOM it worked.

After unplugging the chip I plugged it into an identical circuit board with a pro mini (wireless art install). The computer could not find the board.... issue with the soldering? issue with the what? plugged back into the other board that just worked no dice. Unplugged the ftdi board from everything, waited about 30sec, plugged it all back in, THE ISSUE PERSISTS! GRRRR

Decided to take a break and leave it unplugged. Came back and it worked! unplugged from the pro mini and waited a bit, plugged it back into the same pro min, same issue. Waited a while (not sure how long), plugged into the chip I have not uploaded the beta code to yet and it worked!

SOLUTION: unplug the ftdi chip. let it sit for a while, not just 30sec watching the time, and try again. I tried many other steps that could have helped fix the issue but... it does annoyingly seem this is the solution. I did not create this project using this machine or Mojave so wonder if this is something new or specific with usb-c / mojave / some other hardware issue.

any ways... my hopes with this post are to help someone save time while searching for this issue.


Thanks for taking the time to share your discoveries. That sounds like an extremely frustrating problem. If you can afford it, I would recommend buying another FTDI. That way you can see if the problem is isolated to only one, and you will have a backup to keep you up and running in case one dies.