Mac not uploading Uno

I'm new to the Arduino world and I've been having issues with uploading anything to my new Arduino Uno. I'm using a Mac OS X version 10.4.11. Basically, whenever I hit upload to 1/0 board it says "stk500_getsync(): not in sync: resp=0x86" and then shortly after, "stk500_recv(): programmer is not responding". I can't find the board if I search the computer, but it is getting power from the computer. Thanks in advance for any light that can be shed on this situation.

Have you installed the driver? It comes in the .dmg with the Arduino IDE. Also, make sure you chose the right board (tools>board) and right port (tools>serial port).

Have you installed the driver? It comes in the .dmg with the Arduino IDE. Also, make sure you chose the right board (tools>board) and right port (tools>serial port).

I didn't think the Uno needed to install the drivers? (you're referring to the FTDI drivers?) I ended up doing it anyway because I'm a guy and don't read the instructions

(found the instructions)

3 | Install the Software

Copy the Arduino application into the Applications folder (or elsewhere on your computer). If you're using an Arduino Uno or Mga 2560, you don't have any drivers to install. Skip ahead to the next step.

Go ahead and follow these steps, if it still doesn't work, call again in the morning (yay doctor advice)

K. Can you list all of the options that are in the Serial Port menu?

The options in the serial port menu are as follows:


All of the Bluetooth ones are bluetooth (duh)... Which one are you selecting? You probably want the TTY one.
(It's odd, though. Mine is /dev/tty.usbserial-A800eFDb)

I also found this from ladyada:

See if that helps... mentions stk_500, but not your exact error.

Good Luck!

First, the Uno does not need a driver installed for Mac OS X or Linux. Only Windows. Installing the FTDI drivers will not hurt (nor will it help).

The error you are receiving is a generic error and doesn't really help. Which is rough because I think it is the only error. :slight_smile: Just by observation, I believe there is an issue with Auto-Reset working correctly on OS X 10.4.x and the Uno. This may or not be true, just seems like a pattern I've noticed.

The entire process works like this: The IDE complies the sketch and then uploads it to the board. The upload begins a few seconds after the message "Binary Sketch Size: XXXXX bytes (of a XXXX byte maximum)". Normally the virtual serial port's DTR line gets activated which causes the ATmega328 chip to reset. On reset the Arduino bootloader is running and it waits 2 seconds for serial data. If this reset never occurs, you get the generic error.

Try this...

So while compiling, press and hold the Uno's reset button. About 1 second after the "Binary Sketch Size" message appears, release the button. You may have to play with your timing a little to find something that works.

Thanks! :slight_smile: Holding the reset button did the trick. It's a bit inconvenient, but so long as it works and I can program the device, I'm satisfied. Are there any permanent fixes for this?

Possibly. [That means no] But...
You could try re-burning the bootloader. (Doubt that would help). Or contact whomever you got it from and ask for a new one. (It's defective!)
But back in the good ol' days, everyone had to manually reset their NGs and such.

Burning the bootloader is an option, but probably won't result in a fix. In this specific type of case, the problem is really how OSX handles "usb modems". I use quotes since that is what the Uno is emulating.

If you have a ISP you could try re-programming the 8u2. If you can bare to go a few days without a Uno, it might be worth swapping out for another one. However, I don't think you're going to see a difference in another board.

I have 10.5 and 10.6 and it works just fine, so maybe you can get an upgrade?

I'm a Linux user, but I think I can help:

The usbmodem devices are your Uno - the Uno and the mega2560 use the 8u2 usb interface chip, and are programmed to look like modems, so Windoze users don't need a driver... All older Arduini use the FTDI chips, and their driver

AFAIK the Uno has essentially the same 8U2 boot loader as the mega2560, and there is a BUG in it that will cause the symptoms you see. You can reflash the 8U2 just using the Uno itself, if you can obtain a program called dfu-programmer, and plug in two bits of wire. The new (bug fixed) firmware ships with v0022 I think.

Look on the old forum for instructions - I have no idea whether Macs have a C compiler to build from source. Many of the posts concerned the 2560, and I certainly described where the wires go on the 2560 (the photo is for the Uno)

Good luck - once the bug is fixed the serial should be reliable

If my very recent experience may help...

OK, yesterday I received my Uno board, I connected it to my MacMini and run the Blink test but this failed, I had the RX TX blinking OK but got the error message : avrdude : cannot connect to programmer.
I tried various things, such as power the board with an external PSU but could not get it to work, until I plugged the USB chord directly to the MacMini, until then it was plugged to the USB hub of my Macintosh Display.

Now I plug it directly to the computer and I avoid using the hub. This is not due to a power problem with the hub since it did not operate correctly even when powering the Uno board with an external PSU. This is strange because I use the hub to plug and power an usbpicprog without problems.


I'm encountering a similar problem on Mac,

First I bought Arduino Mega 2560 and installed FTDI driver. I'm using Mac Sierra. All worked fine and each time I connect to it.

Then I also bought Arduino Uno and installed CH340 drivers.
Now Mega 2560 sometimes works, sometimes not. This morning I plugged it in, it worked for around 2 hours and then Arduino suddenly stopped. If I unplugged and plug in again, it does now show desired port in list of ports in Arduino IDE. Restarting Mac sometimes helps, sometimes not.

It is important to note that I'm using Mac 2017, without a USB port, so I'm using USB HUB to connect Arduino via USB cable. Can it maybe cause issues? Of maybe some other program is using same PORT? Or maybe these 2 drivers (FTDI and CH340) are somehow interfering in some moments?

I mean, it is totally inconsistent, sometimes it works, sometimes it simply disappears. Sometimes first restart of Mac helps, sometimes I need to restart 2-3 times to make it work.

Thanks you very much in advance,


This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.