Mac OS X: Open Serial Port-Issues

Hello forum,

greetings from Bremen, Germany, with the following issue: I cannot upload sketches to Arduinos or other connected boards with Arduino-IDE because of busy serial port, even the easiest blink-program.

The problem seems to be an open serial port that is connected to an EV3-program. Although I no EV3 connected there is the 'EV3-SerialPort' listed in my port list. I connected the Arduino device to a make which was not connected to an EV3 yet, and everything worked perfectly.
The mentioned serial port is also listed as '/dev/cu.EV3-SerialPort' or 'dev/tty.EV3-SerialPort' without anything connected.

Does anybody know how I can get rid of this open serial port?

I already read the following posts and topics:

Thanks in advance,


Problem solved: I had bluetooth-connection settings for the EV3 saved , and these setting somehow led to difficulties with connecting Arduinos. After I deleted these EV3-settings everything is fine now.

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.