mac problems

I have been using Arduino with no probs on my PC but have encountered endless problems on my iBook running OSX (10.2.8). Friends with much better Arduino / Computer skills have also failed to get it working.

The major error message is when trying to upload to the board, is as follows: dyld: /Users/fredgutt/Desktop/arduino-0003/tools/avr/bin/avr-gcc can't open library: /usr/lib/libiconv.2.dylib (No such file or directory, errno = 2)

I have also tried to bypass this by having a code already uploaded to the board (from my PC) but this also results in error messages.

Can anyone help me? I would really like to get Arduino working on my Mac!

Thanks in advance!

The easiest (but expensive) solution is to upgrade to a newer version of OS X. Alternatively, you might just be able to install libiconv, but you may also be missing other libraries. For instructions, see: (under “Installing the Necessary Perl Modules”, but stop once you get to the Perl part). You’ll also need to make sure that the libraries get installed in /usr instead of /usr/local, so you’ll probably need to run: ./configure --prefix=/usr instead of just ./configure.

Hi Mellis,

Thanks very much for the reply. I have tried installing the libraries without any success (I am no Mac expert!) so think I will try upgrading my OS... Do I have to get Tiger, or will Panther have the necessary libraries?

Thanks again.