Mac serial port "in use" message

I am very new to the Arduino board. It's a Duemilanove ATmega328. I am powering it off my MAC via a USB cable.

For my first attempt, I had successfully compiled and uploaded the simple Blink One example. I noticed the on-board LED ("L") kept on blinking even after I removed the LED I had plugged into the #13 location (which is the LED that is the focus of the sketch, not the on-board one).

I have tried the reset button, restarting my MAC, unplugging, etc. The on-board LED keeps blinking.

So I ignored it. I then tried to upload the very simple example for the multi-LED series of blinks. It compiles just fine. But when I try to upload it I get the message

"Serial port '/dev/tty.Bluetooth-Modem' already in use"

I have applied all the tips in the Troubleshooting Guide, but no luck. I sense that I need to somehow "clear out" the first program because it is tying up the port.

Is there something simple I can try to fix this?

With the Arduino connected, launch the software, Go to the Tools Menu, then Serial Port and chose the /dev/tty-usbserial-XXXXX. Try uploading again.

Matt