MAC - will not find Arduino in PORT menu

I've tried to upload to my arduino uno but I only see a dev/cu.Bluetooth-incoming port.
I've turned off my computer's bluetooth, mouse and keyboard and still nothing.
I tried resetting arduino board too.
I'm running Mojave, perhaps that's the problem?

Try using a different cable you know works for data or verify the cable you're currently using works for data on another device. You might have a charge-only or defective cable.

If you're using a USB 3.0 port, try using a USB 2.0 port instead.

It's always something silly.
Thanks you.
you're a genius

You're welcome. I'm glad if I was able to be of assistance. Enjoy!

I am having the same problem,
Board: Adafruit Circuit playground express
I have verified my cable
MacOS 10.14.1
I have verified the cable by connecting an android phone, and using android file transfer to copy files back and forth to and from my phone.

Additional info:
For some reason the volume associated with this board is read only.
I can connect the board, see the file system read and copy files off the board, but can not write to it.

Any help greatly appreciated.