Macintosh Serial Ports Not showing Up with Adruino

We just purchased an Adruino Uno, and are using a Macbook Pro, OSX 10.8.5 When we try to upload our blink program, we get an error message:

avrdude: ser_open(): can't open device "COM1": No such file or directory
ioctl("TIOCMGET"): Inappropriate ioctl for device
Problem uploading to board.

When we try to set the serial port from the tools menu, they aren't there.

We've tried installing two different drivers from the web with no luck.
We've restarted the computer and the board.

Does anyone have ideas about this issue?


"COM1" is a Windows name and certainly not right for a Mac.

When you connect the Arduino UNO to a USB port do you not find "/dev/cu.usbmodem1411" (or similar) under Tools->Port? Have you tried a different USB cable? Have you tried a different USB port?

Hi Johnwasser--Thank you so much for this reply. In the manual the port showed up under "serial ports" in a sub menu, but with your suggestion I found the right port and now it works! Thanks so much!!!!!


Hi, I was getting a similar error message, and ended up in this thread. However it turned out that my issue was with the micro-USB cable, which was actually powering my M0 board, but was also causing similar communication issues. I just switched the cable and got rid of the error.

This might be useful to someone else as well. The cable which didn't provide communication was the cable provided with the OnePlus One phone.