MACOS Sierra and Arduino UNO-no serial port found

I am trying to connect my Arduino to my Mac and no serial ports are found. I've spent hours looking through forums, but there don't seem to be any solutions for the Mac Sierra. My computer seems to recognize that it exists when I dig deep into the hardware, but it won't display it anywhere else. I've tried rebooting my computer, redownloading the software, and all the USB ports. I even tried my Arduino Uno on my friend's PC and it works. I'd rather not buy a new computer though. If you know any ways of connecting the two, I would appreciate it. I'm building a robot for school and it's gonna be pretty cool.


You probably need to download the updated usb chip driver. I had the exact same problem with Sierra after the update. It seems the problem is that the old drivers were "unsigned". Apple has gone stupid about this ultimate control of your machine and their software. Try this:

Apple hasn't gotten stupid, but I agree there seem to be lots of problems with the Cheap Chinese UNO knockoffs.

I've been using Arduino on a Mac for a number of years and have gone through numerous Arduino IDE
upgrades and Mac OS X upgrades, including the recent Sierra OS and Arduino 1.6.12. My genuine Arduino UNO and Arduino Mega2560 have never given any USB connections issues. About 99.9% of the time, I use my own boards for the ATmega328P and ATmega1284P devices and I connect to these boards using a FTDI USB connection. The driver from FTDI has always worked and continues to work with Sierra.

These days I use the ATOM editor, with the Arduino IDE set for use with an external editor, and all of my Arduino files are on the iCloud Drive. The Arduino IDE has no problems loading and compiling files from the iCloud Drive.

I can only say that if you're having problems with Sierra and Arduino, perhaps it's time to support and get the real product. The extra few bucks in cost is definitely offset by the peace of mind.

Rant over :slight_smile:

Well as a mac user since the system 6 days I respectfully disagree about Apple going stupid. I updated my iphone to iOS 10.0.2 and after that my iTunes on the mini running 10.8 wouldn't recognize the phone so I was forced to update the OS on the mini. After downloading said update it took me well over a week to get everything thing working again. Since my wife and I live off the grid in the back forty of the boonies we have to use our cell phones for net access. This meant updating all sorts of software that ran flawlessly prior to the update. In turn this meant using huge chunks of our data plan. On top of all that there are no longer export progress bars in iMovie, so it appears Apple thinks such user information is useless. I stand by my opinion because all of this was because Apple had to fix a security flaw in the phone OS. They couldn't just fix the flaw. They made a decision to force a new OS on those of us which use our macs to archive photos and such. Siri on my mac? I don't even use Siri on my phone. My next computer will not be an Apple. I am done with their micromanaging of their users. I made my living as a graphic and web designer for over 20 years exclusively on a mac, and I am done. Surely I am allowed my own well formed opinion on the matter.

As for buying exclusive real Arduino products allow me to say this. I have never bought any Arduino boards ever. I was given all of mine. Yes, each one is a clone. In some parts of the world getting your hands on a genuine Arduino board can be next to impossible. So, those statements come across as elitist first world condescension to me. Offering advice which helps other Arduino users is also supporting the Arduino community, it just doesn't pay someone's salary. It comes across to me as the same rigid conformity demanded by Apple computers.

Perhaps this forum is not for me after all. While there is a great deal of useful information here there is also a tone of superiority displayed on a repeating basis that reeks of a ruling class.

For me the problem was a cable that came with Chinese clone.

No serial port for original uno r3 as well as for the clone, it looks that cable is just for the power.

I am trying to connect my Arduino to my

If it is not an official Uno, then you probably need to install drivers. There three possible chips being used, that require drives. CH340, CP2102, and FTDI FT232. Listed in order of most likely.

Official boards come with an atmega16u2 configured as a USB Modem, so they don't require drivers (on Mac and Linux). They do cause an entry to show up in System Preferences -> Network. But nothing needs to be done with it there.

My computer seems to recognize that it exists

If you're looking at System Information and you see one of the part numbers I list above, then you need to install drivers.

I am actually having this same issue on my new Mac Mini running High Sierra. No usb serial ports are found from the App. It just keeps showing Bluetooth. :frowning: . I installed the CH34 drivers, the FTDI drivers, and still nothing. This all worked on my Retna laptop.. is it the Mac os version, the Mac hardware is crap now or what? The Arduino board is a Duemilalove board.. original, not a clone, it should work. Any ideas out there?

Oh my.
Not only does it seem possibly the cables, but a janky micro usb port on the device...
ensuring no pressure upward from the stiff cable, makes it connect better...
This is a pair that have pin headers pre-soldered, so perhaps the doing of that made something loose :frowning: >:(