Major software issues with internal osccilator bootloader

Hello
As I mentioned in another post, I was having major issues with using the internal oscillator on the atmega 328P-au. Link to that thread: Problem with atmega 328p-au serial communication - Project Guidance - Arduino Forum

I have been searching for a compatible "Atmega328P on breadboard" boot loader with IDE version of 1.8.8

Almost everything seems broken when using the latest files which are meant for IDE 1.6.x and I'm not sure how to adapt it to the newer version. If anyone has the new boot loader or knows how I can modify the previous version to work with the new IDE, I will be thankful.

This is what I use.

Minicore/atmega328p/internalOscillator@8MHz