Make your device IoT-ready | not working

I am trying to set up two new Arduino MKR WiFi 1010 boards, with the same result: the process stuck at step 3, with a “Configuring Secure Element…” message. After several minutes, the message changes to We were not able to configure your device”.

I think that it could be related to the WiFiNINA library, but I unsuccessfully tried to update it through the IDE or the Web Editor.

There is also an error that says:

SyntaxError: JSON.parse: unexpected character at line 1 column 1 of the JSON data

I will appreciate any help!

You posted no code. How are people expected to help?

When you get an error, do you really think it is the library's fault? Lots of people use libraries as well as the author testing the example code so that is highly doubtful. It is your unseen code that is the problem.

I am sorry, but in this case there is no code to post!

I am using the Arduino IoT Cloud.

  1. I go to the Devices tab, and click the Add Device button.
  2. I then click the Set up an Arduino device
  3. The browser scans and tells me that it found an Arduino MKR WiFi 1010
  4. I click the Configure button
  5. The system asks me to Give your device a name
  6. The system go to the Make your device IoT-ready
  7. It fails with a We were not able to configure your device message

There is no code to show, I am sorry. What I said about the library was based on previous experience, and it does not invalidate the fact that I cannot configure a new device with the Arduino IoT Cloud.

The computer I was using is an iMac with OS X El Capitan (version 10.11.6), and Firefox 78.12.0esr (64-bit). The Arduino Agent is version 1.2.3-b696989.

I went to a different computer, another iMac, this time with MacOS Mojave (version 10.14.6), Firefox 90.0.2. The Arduino Agent is version 1.2.3-b696989.

On the second computer, I could configure the two devices in a breeze. I deleted them, went back to computer #1 – older system and browser – and now I could also add them there.

My understanding: the process need to run some update (e.g., the WiFiNINA firmware update) that cannot run in an older system. The boards have WiFiNINA 1.4.5 before and after getting recognised by the Arduino Cloud they have version 1.4.7. The latest one seems to be 1.4.8, but the Arduino IoT Cloud now recognises the boards.

Any thoughts?