malfunzionamento GRBL mega con mega 2560

Salve chiedo aiuto
Sto da poco provando a pilotare dei motori nema 24 con grbl tramite un arduino mega 2560 della kuongshun ho cercato e scaricato su google il GRBL adeguato al 2560 e una volta aggiunta la libreria e caricato il codice aprendo il monitor seriale impostando il corretto baudrate sembra funzionare tutto ma appena inserisco il classico comando "$$" vengono visualizzate queste coordinate

Grbl 1.1g ['

e cercando di inviare il comando "G0 x10y10z10" non succede nulla
ho provato anche con un arduino uno normale di un amico e con quello 0 problemi.
Qualcuno saprebbe dirmi come risolvere il problema? grazie in anticipo for help]
[MSG:Check Limits]
[MSG:'$H'|'$X' to unlock]
$0=255
$1=255
$2=255
$3=255
$4=1
$5=1
$6=1
$10=255
$11=2147483.648
$12=2147483.648
$13=1
$20=1
$21=1
$22=1
$23=255
$24=2147483.648
$25=2147483.648
$26=255
$27=2147483.648
$30=2147483648
$31=2147483648
$32=1
$100=2147483.648
$101=2147483.648
$102=2147483.648
$110=2147483.648
$111=2147483.648
$112=2147483.648
$120=2147483.648
$121=2147483.648
$122=2147483.648
$130=2147483.648
$131=2147483.648
$132=2147483.648
ok


e cercando di inviare il comando "G0 x10y10z10" non succede nulla 
ho provato anche con un arduino uno normale di un amico e con quello 0 problemi.
Qualcuno saprebbe dirmi come risolvere il problema? grazie in anticipo

Così ad occhio direi che non hai impostato correttamente il software oppure non hai collegato i finecorsa dato che come primo messaggio si legge:
[MSG:Check Limits]

[MSG:Check Limits] - If Grbl detects a limit switch as triggered after a power-up/reset and hard limits are enabled, this will appear as a courtesy message immediately after the Grbl welcome message.

Controlla i collegamenti! (magari utilizza anche un filtro per smorzare i disturbi)

si si lo so che mancano i finecorsa ma con arduino uno l'output nel monitor seriale è diverso

[HLP:$ $# $G $I $N $x=val $Nx=line $J=line $SLP $C $X $H ~ ! ? ctrl-x]
ok
$0=10
$1=25
$2=0
$3=0
$4=0
$5=0
$6=0
$10=1
$11=0.010
$12=0.002
$13=0
$20=0
$21=0
$22=0
$23=0
$24=25.000
$25=500.000
$26=250
$27=1.000
$30=1000
$31=0
$32=0
$100=250.000
$101=250.000
$102=250.000
$110=500.000
$111=500.000
$112=500.000
$120=10.000
$121=10.000
$122=10.000
$130=200.000
$131=200.000
$132=200.000
ok

e tutto funziona correttamente anche senza i finecorsa

Se leggi il manuale prima di provare a caso magari riesci a configurare correttamente il software...

Grbl v1.1 Configuration

$5=0 Limit pins invert, boolean

dato che nell'output della tua versione 2560 $5 vale 1 senza collegare correttamente i fine corsa riceverai il messaggio che ti dice di controllare i fine corsa... MSG:Check Limits

Con arduino uno non hai quel messaggio perché la configurazione è corretta e $5 vale 0.