Marlin

Slave a tutti sto provando a compilare il mio Marlin per una stampante Anet A8 ma quando sta per finire il compilatore Arduino va in blocco, non riesco a capire il problema do dove parti.

Ti segnalo che, nella sezione in lingua Inglese, si può scrivere SOLO in Inglese ... quindi, per favore, la prossima volta presta più attenzione in quale sezione metti i tuoi post; questa volta è stato spostato nella sezione di lingua Italiana ... la prossima volta potrebbe venire direttamente eliminato ::slight_smile:

Guglielmo

mrcamarium:
Slave a tutti sto provando a compilare il mio Marlin per una stampante Anet A8 ma quando sta per finire il compilatore Arduino va in blocco, non riesco a capire il problema do dove parti.

Qualche informazione in più ??

gpb01:
Ti segnalo che, nella sezione in lingua Inglese, si può scrivere SOLO in Inglese ... quindi, per favore, la prossima volta presta più attenzione in quale sezione metti i tuoi post; questa volta è stato spostato nella sezione di lingua Italiana ... la prossima volta potrebbe venire direttamente eliminato ::slight_smile:

Guglielmo

ho il traduttore attivo sulle pagine quindi mi è difficile capire quando il sito è in inglese, per la prossima volta farò più attenzione.

In che senso va in blocco? E se no lo compila che errori ti da il compilatore ?

mrcamarium:
..sto provando a compilare il mio Marlin...

Ce lo fai vedere anche a noi "il tuo Marlin" che non si compila?

Ciao,
P.


Adesso sono costretto a riavviare il PC perchè non lo posso più chiudere.

Metti il verbose alla compilazione in impostazioni, ingrandisci quella finestrella (prima di iniziare a compilare) alzandone la dimensione

ho capito doverà il problema, il tempo. Cioè ci impiega circa 20 minuti per compilare sto script.

Sul fatto che ci mette un po’ a caricare è del tutto normale, anche il mio Marlin ci impiega un po’ a caricare, ma 20 minuti sono decisamente troppi. Prova a compilare il programma con una versione più datata dell’ide (tipo la 1.9) e simili. Sicuramente non penso sia un problema dello sketch ma piuttosto dell’ide

ho risolto il problema lanciando l'ide da una macchina virtuale, adesso funziona e ho aggiornato la mia stampante che adesso va molto meglio rispetto a prima.