MATERIA 101 - several issues at the end of assembly

Everything seems good with wires and for example, the fans work and I succeed adjusting potentiometers to 0.4 or 0,5 V but:

-When turn Materia 101 on, green led only turn on twice for a second and the green light disappears (a red one on se same board turn on and remains)

  • The screen is not usable (or with many difficulties reading it in the dark with a specific angle) since all pixels seems turn on! very difficult to red the menu but the menu is displayed. This only happens with 12V power supply. With USB power the screen (and menu) is ok
  • the screen said "error NOTERM"
  • the SD card is not seen too

Any idea to help me?

sorry, not "error NOTERM" but "MINTERM"

I also suspect to have made a wrong using the command "burn" (erasing the boot sequence possibly) when I tried to upload the firmware... Any Idea to restore the original boot sequence?
Any help?

I had an issue when I initially installed mine as well. For me it took 2 or 3 attempts to download the firmware before I successfully did so (unfortunately if the Arduino IDE download told me that the download didn't work properly I didn't understand it). The other thing that you may want to do is make sure that the firmware that you downloaded was complete and not corrupted.

About the screen, after you sort the firmware out, making sure you uploaded it correctly, if it still doesn’t work you can try to adjust the contrast potentiometer at the back of the I/O board (the one holding the screen). Also, if you get any error on the lcd screen it means that the firmware is loading correctly but maybe you misconfigured it, because if the processor fails to boot or the firmware is corrupted it has no way to talk to the screen.

p.s. I have no way to check this right now, but I’m pretty sure the potentiometer is somewhere on that board.


Thank you for your help,

Good idea DP, I found the potentiometer and it solved the screen issue!!

Now, I'm only facing two issues:

  • Understand why when I use the external powersupply I got both no SD and Minterm errors (with temperature still to zero)... Since when I use the same power supply device directly on the mainboard, it recognizes the SD card (and load it), fans are working, got the data on X,Y and Z axes, and temperature goes up to 170...

-Why in both cases, I am not able to move any X,Y, or Z motors...

I can try again to download firmware but I already get twice a success message for this task. May be I did a stupid thing burning a wrong boot sequence, no idea how to burn the original one?

Best regards,

The boot sequence has nothing to do with your problems. If it was faulty you wouldn't be able to see anything on the screen.

What do you mean by 'external power supply'? The dc transformer or usb power?

One DC transformer pluged in the external plug of the printer: the one with is linked to the on/off switch and to the Ramps. The normal way to power the printer.
When I use it, I have "Minterm" error, SD reader is not recognized but fans are working and when preheat, I can feel temperature on the extruder head. No way to move steppers and no recognition of their coordinates.

If I try something quite different. If I plug the (same) DC transformer directly on the Mainbord (mega 2560), then:

  • no minterm error, no fans
  • temperature and X,Y,Z coordinates are ok
  • SD redaer is ok and I can read (ok, only 4%) of the file on it
  • X, Y ,Z coordinates are acquired
  • no way to move steppers anyway

It looks like (only my feeling) that the Ramps doesn't correctly supply power to the 2560... but I can't see why...

(power supply (DCtransformer) seems ok and gives 12V)

If you plug your power supply into the 2560 it does not supply all of the power needed for the Ramps board tow work properly: Apparently the design of the ramps board is to provide proper power through the 4 pin switched power connector on the Ramps board. I checked this on my setup and found that the motors will not work with power to the 2560. The input panel works, but it will not send the signal to the fans or motors. This is understandable, as the Ramps board is the controller and derives it’s power through it’s pin connections and at the same time provides power to the 2560.

As far as you getting an error and your XYZ motors not working, you will have to check your wiring and your mating of the two boards. as I recall, some one on the site had a problem similar and it was caused by not pushing the to boards together completely. The site Guru Moderator: kengdahl has a picture showing the proper connection of the two boards, but you will have to search for it as I do not remember the location. One other thing to check is if you have the motor connectors to the Ramps board reversed or one pin off.