Matrice led 16X32 rouge

bonjour,bonsoir
depuis quelque temps jai une matrice led 16X32 apres des recherche jai trouver comment le câbler et un code pour test `#include <SPI.h>

#include <DMD.h>
#include <TimerOne.h>
#include "Syste
mFont5x7.h"
#include "Arial_black_16.h"

#define ROW 1
#define COLUMN 1
#define FONT Arial_Black_16

DMD led_module(ROW, COLUMN);

void scan_module()
{
  led_module.scanDisplayBySPI();
}

void setup()
{
  Timer1.initialize(2000);
  Timer1.attachInterrupt(scan_module);
  led_module.clearScreen( true );
}
void loop()
{
    led_module.selectFont(FONT);
    led_module.drawMarquee("Welcome to Circuit Digest",25, (32 * ROW), 0);
    long start = millis();
    long timming = start;
    boolean flag = false;
    while (!flag)
    {
      if ((timming + 20) < millis()) 
      {
        flag = led_module.stepMarquee(-1, 0);
        timming = millis();
      }
    }
  }

`

16x32 Red LED Matrix Panel P10
ou je lais acheter

mes sa marche pas (pas du tous) il y a juste quand je met vcc sur la broche 6 nommer A sur le shema

C’est quoi comme module ? Tu as une référence, une image, un site marchand ?

le site ou je lais acheter je lais mie un peux plus haut malheureusement jai pas grand chose j’ai sa je sais pas si sa peux aider

Je crois que tu ne rentres pas sur le bon connecteur

l’autre s’appelle output (celui qui est pas câbler je lais décâbler pour prendre ka photo 2 ou on vois le connecteur les
N sont relier entre eux
OE broche D9
A broche D6
B broche D7
F borche D13
S broche D8
R broche D11
F relier a rien

(j’ai oublier de le dire mes je suis sur arduino mega 2560 avec un grove mega shield)

Sur la première photo que tu as postée, tu entres sur le connecteur de sortie.
Cette librairie semble utiliser le SPI matériel. Il faut donc modifier les connexions pour utiliser le SPI matériel du 2560 voir ici

sur la premiere photo c’est un 2eme module led qui est brancher (le méme)

bon en spi sa marche pas :sob: