MAX 6675 or any library

Regardless of the library, max6675 or something, I always get errors even though I always load libraries. Even though I upload it from Arduino or as ZIP, I keep getting an error. I have repeatedly deleted and installed the Arduino program, but I keep getting errors. I’m tired now. The program cannot find any libraries. Can anyone help?

I’m going to ask you to post some additional information that might help us to identify the problem.

Please do this:

  1. When you encounter an error, you’ll see a button on the right side of the orange bar Copy error messages in the Arduino IDE (or the icon that looks like two pieces of paper at the top right corner of the black console window in the Arduino Web Editor). Click that button.
  2. In a forum reply here, click on the reply field.
  3. From the toolbar at the top of the editor field, click the </> button
    codetags
  4. Press Ctrl+V. This will paste the error into the reply window.
  5. Move the cursor outside of the ``` code block tags before you add any additional text to your reply.
Arduino:1.8.13 (Windows Store 1.8.42.0) (Windows 10), Kart:"Arduino Uno"





















sketch_apr28a:1:10: fatal error: max6675.h: No such file or directory

 #include <max6675.h>

          ^~~~~~~~~~~

compilation terminated.

exit status 1

max6675.h: No such file or directory



This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.

Please provide a detailed description of how you installed the library.

Arduino - Libraries I followed this instruction and use library manager in arduino IDE. Also I used the ZIP way

Not detailed enough. Please help us to help you. We can only provide the solution if you make the effort to give us the information we need.

There are thousands of libraries in Library Manager. Please tell us the exact name of the library you installed.

Please provide the link to the download for the ZIP file you installed.

I used this adafruit library for MAX 6675 thermocouple module and also I used MAX6675 library - Arduino Reference
this link to try to install ZIP, but still ı cant still same error

OK, this is very useful information. Unfortunately, I haven’t spotted the reason for the error yet. I’m going to ask you to provide the verbose compilation output.

Please do this:

  1. Select File > Preferences from the Arduino IDE’s menus.
  2. Check the box next to “Show verbose output during: [ ] compilation”.
  3. Click the OK button.
  4. Select Sketch > Verify/Compile from the Arduino IDE’s menus.
  5. After the compilation fails you’ll see a button on the right side of the orange bar Copy error messages. Click that button.
  6. Paste the error messages in a reply here, just as you did before.
Arduino:1.8.13 (Windows 10), Kart:"Arduino Uno"





















C:\Program Files (x86)\Arduino\arduino-builder -dump-prefs -logger=machine -hardware C:\Program Files (x86)\Arduino\hardware -tools C:\Program Files (x86)\Arduino\tools-builder -tools C:\Program Files (x86)\Arduino\hardware\tools\avr -built-in-libraries C:\Program Files (x86)\Arduino\libraries -libraries C:\Users\Umut  Can\Documents\Arduino\libraries -fqbn=arduino:avr:uno -ide-version=10813 -build-path C:\Users\UMUTCA~1\AppData\Local\Temp\arduino_build_417664 -warnings=default -build-cache C:\Users\UMUTCA~1\AppData\Local\Temp\arduino_cache_80389 -prefs=build.warn_data_percentage=75 -prefs=runtime.tools.avr-gcc.path=C:\Program Files (x86)\Arduino\hardware\tools\avr -prefs=runtime.tools.avr-gcc-7.3.0-atmel3.6.1-arduino7.path=C:\Program Files (x86)\Arduino\hardware\tools\avr -prefs=runtime.tools.avrdude.path=C:\Program Files (x86)\Arduino\hardware\tools\avr -prefs=runtime.tools.avrdude-6.3.0-arduino17.path=C:\Program Files (x86)\Arduino\hardware\tools\avr -prefs=runtime.tools.arduinoOTA.path=C:\Program Files (x86)\Arduino\hardware\tools\avr -prefs=runtime.tools.arduinoOTA-1.3.0.path=C:\Program Files (x86)\Arduino\hardware\tools\avr -verbose C:\Users\Umut  Can\Desktop\sketch_apr28a\sketch_apr28a.ino

C:\Program Files (x86)\Arduino\arduino-builder -compile -logger=machine -hardware C:\Program Files (x86)\Arduino\hardware -tools C:\Program Files (x86)\Arduino\tools-builder -tools C:\Program Files (x86)\Arduino\hardware\tools\avr -built-in-libraries C:\Program Files (x86)\Arduino\libraries -libraries C:\Users\Umut  Can\Documents\Arduino\libraries -fqbn=arduino:avr:uno -ide-version=10813 -build-path C:\Users\UMUTCA~1\AppData\Local\Temp\arduino_build_417664 -warnings=default -build-cache C:\Users\UMUTCA~1\AppData\Local\Temp\arduino_cache_80389 -prefs=build.warn_data_percentage=75 -prefs=runtime.tools.avr-gcc.path=C:\Program Files (x86)\Arduino\hardware\tools\avr -prefs=runtime.tools.avr-gcc-7.3.0-atmel3.6.1-arduino7.path=C:\Program Files (x86)\Arduino\hardware\tools\avr -prefs=runtime.tools.avrdude.path=C:\Program Files (x86)\Arduino\hardware\tools\avr -prefs=runtime.tools.avrdude-6.3.0-arduino17.path=C:\Program Files (x86)\Arduino\hardware\tools\avr -prefs=runtime.tools.arduinoOTA.path=C:\Program Files (x86)\Arduino\hardware\tools\avr -prefs=runtime.tools.arduinoOTA-1.3.0.path=C:\Program Files (x86)\Arduino\hardware\tools\avr -verbose C:\Users\Umut  Can\Desktop\sketch_apr28a\sketch_apr28a.ino

Using board 'uno' from platform in folder: C:\Program Files (x86)\Arduino\hardware\arduino\avr

Using core 'arduino' from platform in folder: C:\Program Files (x86)\Arduino\hardware\arduino\avr

Detecting libraries used...

"C:\\Program Files (x86)\\Arduino\\hardware\\tools\\avr/bin/avr-g++" -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -Wno-error=narrowing -flto -w -x c++ -E -CC -mmcu=atmega328p -DF_CPU=16000000L -DARDUINO=10813 -DARDUINO_AVR_UNO -DARDUINO_ARCH_AVR "-IC:\\Program Files (x86)\\Arduino\\hardware\\arduino\\avr\\cores\\arduino" "-IC:\\Program Files (x86)\\Arduino\\hardware\\arduino\\avr\\variants\\standard" "C:\\Users\\UMUTCA~1\\AppData\\Local\\Temp\\arduino_build_417664\\sketch\\sketch_apr28a.ino.cpp" -o nul -DARDUINO_LIB_DISCOVERY_PHASE

Alternatives for max6675.h: [MAX6675_library@1.1.0]

ResolveLibrary(max6675.h)

  -> candidates: [MAX6675_library@1.1.0]

"C:\\Program Files (x86)\\Arduino\\hardware\\tools\\avr/bin/avr-g++" -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -Wno-error=narrowing -flto -w -x c++ -E -CC -mmcu=atmega328p -DF_CPU=16000000L -DARDUINO=10813 -DARDUINO_AVR_UNO -DARDUINO_ARCH_AVR "-IC:\\Program Files (x86)\\Arduino\\hardware\\arduino\\avr\\cores\\arduino" "-IC:\\Program Files (x86)\\Arduino\\hardware\\arduino\\avr\\variants\\standard" "-IC:\\Users\\Umut Can\\Documents\\Arduino\\libraries\\MAX6675_library" "C:\\Users\\UMUTCA~1\\AppData\\Local\\Temp\\arduino_build_417664\\sketch\\sketch_apr28a.ino.cpp" -o nul -DARDUINO_LIB_DISCOVERY_PHASE

Alternatives for max6675.h: [MAX6675_library@1.1.0]

ResolveLibrary(max6675.h)

  -> candidates: [MAX6675_library@1.1.0]

sketch_apr28a:1:10: fatal error: max6675.h: No such file or directory

 #include <max6675.h>

          ^~~~~~~~~~~

compilation terminated.

Şu dizinde 1.1.0 sürümündeki MAX6675_library kütüphanesi kullanılıyor: C:\Users\Umut  Can\Documents\Arduino\libraries\MAX6675_library 

exit status 1

max6675.h: No such file or directory


I did what you say and I got this error

OK! I see the problem now:

There are two consecutive spaces in the path of your sketchbook folder, from the user name component: “Umut Can”.
There was a bug in Arduino IDE 1.8.13 that caused libraries to no longer be recognized by the Arduino IDE when they were installed under a path that contains two or more consecutive spaces.

This bug has already been fixed, but there hasn’t been a new release of the Arduino IDE since then.

So you have your choice of either of two options to fix this problem. Either one of them will fix it; there’s no need to do both:


Option A: Change your sketchbook folder to a path that doesn’t contain two consecutive spaces. You can set the sketchbook folder location in the Arduino IDE’s File > Preferences > Sketchbook Location. After changing the sketchbook location, you will either need to copy the files and folders from the old location (C:\Users\Umut Can\Documents\Arduino) to the new location, or else to reinstall the libraries.


Option B: Use the hourly build of the Arduino IDE. You can download it here:
https://www.arduino.cc/en/software#hourly-builds


Please let me know if you have any problems or questions.

1 Like

I tried the option B because I couldnt understood the option A I am so sorry, maybe it is because of my english. I wonder if there is video that showing how I can Option A, so I can follow. But the option B, it worked for me thank you so much. I am so happy right now. Thank you again

You’re welcome. I’m glad to hear it’s working now. Enjoy!
Per

1 Like

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.