MAX485, ok with 2 nodes, when 3rd node powered up voltage drop below 2V (SOLVED)

Hi,

I made a MAX485 module with the schematics below…

Everything was working OK when 2 nodes were connected, can Rx or Tx between the master/slave nodes on the Arduino Nano.

  • I have tried using 20K pull-up/down at A,B or even no pull-up/down on A,B, same results.

  • I tried with 120R termination or 1K R termination, same results.

  • Was running at the lowest speed of 9600, same results.

I’m using just very short Cat 5E twisted pair cables during the tests…

I can visually see it is not working as the Rx,Tx LED becomes very dim or not litted at all…

Any idea why does it drop the voltages when 3 or 4th nodes was connected ??

Thank you for reading this…

[url=http://[!(https://farm5.staticflickr.com/4849/31568755707_c258d48691.jpg)](https://flic.kr/p/Q6C8ev)MAX485-sch

When running on 2 nodes, everything was ok.

[url=http://[!(https://farm5.staticflickr.com/4865/45595431695_c3196da684.jpg)](https://flic.kr/p/2ct7vjF)MAX485-2nodes

When connected n power up the 3rd node, voltages dropped below 2V

[url=http://[!(https://farm8.staticflickr.com/7852/31568766147_3fa09fff71.jpg)](https://flic.kr/p/Q6Cbkv)MAX485-3nodes

Here is a picture of my setup with the newly made PCB…

[url=http://[!(https://farm8.staticflickr.com/7870/46456899842_b0fff835d1.jpg)](https://flic.kr/p/2dMeKML)MAX485-Eduboard

Someone in another forum helped me solve it by removing the 10K pullup from the DE/RE pins and allow the Arduino Nano to control the HIGH/LOW state..