MAX6675 library isn't verifying under 1.0.5 r2

Having access to someone with a reflow oven where I’m from is difficult. I am working through putting together an UNO R3, IDE 1.0.5 r2, k-type thermocouple off a MAX6675 breakout board I just received from an Ebay order from China.
I have The UNO working fine as far as programming the use of a tmp36 sensor from an ARDX kit from Seeedstudio I picked up a month ago from RadioShack.

I downloaded the MAX6675 libraries from the arduino.cc library page reference.

I hook up the board to the UNo R3 the way teh sketch list but when I go to verify before I upload, the Arduino 1.0.5-r2 gives an " ‘MAX6675’ does not name a type" error.

/*
 Demonstration sketch for Hobbybotics MAX6675 Thermocouple breakout board.
 
 Reads temperature from MAX6675 in celsius and fahrenheit.  Prints results to serial monitor.
*/

#include <MAX6675.h>

MAX6675 thermocouple;
  
void setup() {
  Serial.begin(9600);
  thermocouple.init(4, 5, 6);
  
  Serial.println("MAX6675 test");
  // wait for MAX chip to stabilize
  delay(500);
}

void loop() {
  // basic readout test, just print the current temp
  
   Serial.print("C = "); 
   Serial.println(float(thermocouple.measure(TEMPC)));
   Serial.print("F = ");
   Serial.println(float(thermocouple.measure(TEMPF)));
 
   delay(1000);
}

It gives Serial_MAX6675_demo:9: error: ‘MAX6675’ does not give a type error.

I have tried the "#include “Arduino.h” fix to no avail.
I have tried the MAX6675-library-mater.zip file with the above fix to no avail
an I have not tried to use an earlier version.
I am not locating anything more current than Jan 2015 for any posts.

I can sure use anthoer set of eyes and brains for troubleshooting this.
Thanks!

Don't you have to pass some parameters to MAX6675, such as

MAX6675 thermocouple(x,y,z);

Paulcet:
That is an excellent question! I am using the demo from the two different libraries I have found and they both are set up this way and both do not pass verification under 1.0.5-r2.

Is this where I use the above mentioned int "SO,CS,SCK2"? such as:

MAX6675 thermocouple(4,5,6);

This is found in the MAX6675.cpp

This is my first attempt at using an SPI device other than an Ethernet shield from Seedstudio.

Here is the library reference I was using as a starting point:

http://playground.arduino.cc/Main/MAX6675Library

Hey Paulcet: It helps if I can PFATWIR (Pay Full {pc} Attention To What I Read).
The example I listed is not the one on the reference library page. I have the samples mixed up some how.

Gee, I gues you where the second set of eyes and Brain that I needed to get me over this issue. Thanks!!!!!

Upon further research, once I set the SCK to SCK2 (in two places in the example) I initially posted, it verifies and uploads, and works AOK!

I had confused the Adafruit MAX6675-library-master.zip, with the MAX6675-library-master.zip that is linked to in the MAX6675 library post on the Playground.

It helps not to mix and match. Jeepers, it must be FRIDAY!

Solved!