MAX7219 madness


I try to drive a LED display with MAX7219 and Arduino. I use LTC-2727G common cathode 7-segment/4-digit display, which is previously successfully multiplexed with Arduino. But this time i need more free pins, and i selected MAX7219 for driving the display.

The problem is, that if i run the MAX7219 7-segment example from LedControl library, all digits show "8", all segments light up, and nothing happens.
I can see that the MAX is writing characters to the first digit (but only there), because the first digit lights up sometimes brighter as the others.
What can cause this? I tried different values for Rset, but nohing changed.
My first thought was a shortage, but for all the 4 digits? Noooo :smiley: MAX7219 is brand new... Communication is OK...

Has anybody seen anything like that? Any help would be appreciated...

Would be helpful to have a circuit and the sketch.

Have you wired the segments and digit selections the right way round?

I will upload the circuit, but i think it is mostly OK. (3 wires to MAX, and from that, wires to the LTC2727...)
It is possible that it is miswired, but i will check only tomorrow (and, miswired? for all the 4 digita? :slight_smile: and all segments are lighting? :S ). Sketch is uploaded from LedControl library's example, without changes (except pin definitions).

Schematic and PCB :

Link :

I had to use lots of wires, due to small pcb size :frowning:
(It is a desk clock with a thermometer, very simple.)

Usually worth trying the really obvious things first.

I added scematic adn PCB to the first entry.
I took a short measure, and there is 5V on every digit outputs on the MAX...

OK guys, sorry for dumb questions! Error was a miswiring, the Max's Dig4 output was wired to the Adruino's A5, which i used for DIN to the MAX. So it haven't got any data received :smiley: I think the error happened during the toner transfer, which after i have corrected the wires, whose were not transferred correctly.
Now it is working fine, thanks :slight_smile: