Maximized view of the Arduino IDE window on startup not working

HI all, I can't seem to have the Arduino IDE open up in its 'maximized' view on clicking the Arduino icon from my task bar. Is this just the way it works?

Right-clicking the task bar icon, I set the 'Properties' to run in a maximized view and it just doesn't seem to be "sticking". Its a minor nuisance as far practicality goes but that issue starts lurking in my head some sketches get glitchy. It starts making think I have a corrupted IDE install. (I just installed an update to 1.8.5 just to ensure, possibly incorrectly, I am working in a well known and stable version.)

Almost forgot, I am working in Windows 7.

Thanks!

Some possible help for re-installs of the IDE attached

CLEAN UP BEFORE INSTALLING ANOTHER COPY OF THE IDE OR ARDUINO CREATE.pdf (347 KB)

Thanks for the rpely! Even though its a list of stuff I did not do! LOL

Anyway, just before getting your reply I went to 'uninstall' anything looking odd having to do with Arduino IDE, but the only thing that looked odd was that I found no evidence of the Arduino IDE installed! I know its there because its running from my task bar at this very moment.

Any idea why its (either the old IDE v 1.6.7 or the current IDE v1.8.5)?

Did I make an even larger blunder in my inital install (other than doing the things you suggested, that is)?

It is possible to have multiple IDE’s and versions of IDE’s running.
A lot depends on if you used the Zipped versions or the install versions.

Can currently choose from 6 of them here depending on what the help topic is in the forum and I know some members have more than that.

It is also the reason I made those notes to help me as much as anyone else LOL.

Current IDE is 1.8.8 but 1.8.5 is quite stable.

If you really want to start afresh follow my help guide to the letter

I have noticed this too, over many IDE installations an multiple computers and Windows versions. I seem to remember that years ago one of the Arduino developers claimed the IDE had been changed to open at the last size but it never changed for me. There is a last.sketch.default.location property in preferences.txt which does store this information but it doesn't seem to be used.

I've also tried the "Run: Maximized" trick. In older IDE versions that used to cause the startup splash screen to be maximized, but not the IDE. I'd guess that's a clue to why it doesn't work.

What you can do is set the default IDE window size by editing preferences.txt:

  • Click the link on the line following File > Preferences > More preferences can be edited directly in the file. This will open the Arduino15 (or similar folder name) folder.
  • Close the Arduino IDE.
  • Open the file preferences.txt in a text editor
  • Change the editor.window.height.default and editor.window.width.default properties to your desired window size.
  • Save the file.

This doesn't actually open it maximized, which I would prefer, but it's better than the ridiculously small default window size.

Just tried this with 1.8.7 - 1.8.8 - and it appears to work (windows 7 x64)

Open editor.
Maximise.
Load a sketch.
Compile.
Close IDE.

Re-open IDE.
Here it opens pre maximised.

Does seem to be the earlier IDE’s that suffer this issue.

@pert: Yeah, I get that splash screen maximized, too, then it settles to that tiny 'playskool-sized' image. Like I said, it is only a minor nuisance but it did have me concerned about something possibly more serious with my install.

@ballcsrewbob: Thanks, I may just "upgrade" again... this time following those pre-install cleanup recommendations!

I am less concerned now. Thanks to all!


Updated: 12/30/18. Following a reload of IDE v 1.8.5, the issue resolved itself. I did nothing special aside from going through the steps you'd odinarily go through (same as those recommended in the replies....thanks, again!)

The IDE opens with the usual small splash screen and the "maximized" view now pops up when you would have ordinarily expected it.