McuFriend 3,95" Ili9488 Not Works

Hello:

I bought a McuFriend 3.95" ili9488 TFT but not works. I already have a similar that works correctly with the library uTouch and R61581 driver.

The problem is that I am not able to run the new screen (always white). I have tried all the drivers of the library uTouch unsuccessfully (ili9488 The driver is not in it).

Can anyone help me ?, thanks

I forgot to say that I'm using a card arduino Mega. Sorry

Well, you obviously have a Shield that is designed for a Mega2560 / Due. The clue is in the 18x2 header pins.

You have 2 resistor packs for the XPT2046. And only 4 resistor packs for the microSD and TFT.

So you probably have an 8-bit parallel interface. I suspect that your "other" shield has 7 resistor packs for the microSD and TFT.

Life would be so much simpler if you posted a link to your actual displays.

Since your shield says ili9488, I would think this should be a pretty big clue for the controller.

It is fairly unlikely that UTFT has got an 8-bit driver for an ILI9486 (or ILI9488). The UTouch should work with any of these Shields. They all have an XPT2046 Touch Controller and all use the same Arduino pins.

David.

Sorry, I confused with photos, I have 2 TFT:

The 2 cards are mounted on a mega arduino.

One of them works properly with the library Utft and Driver R61581 (TFT works ok.jpg),
another does not work with any driver of the Utft library, the screen it´s ever in white (TFT don’t Work.jpg).

Thanks.

You probably bought both displays on Ebay or AliExpress. Why not provide links to the actual sale items?

Yes, your "working" JPEG shows 7 resistor packs for the microSD and TFT. What is printed on the pcb ?

I would be very surprised if it is a Renesas R61581. But hey-ho, UTFT users don't really care what driver they use.

Note that UTFT v2.8.2 has just been released. Have you checked whether there is an 8-bit ILI9486 driver ?

David.

The links are lost, I bought in aliexpress.
In the PCB it is printed the same: [3.95" TFTLCD for arduino mega 2560(ili9488)].
I assure you that the sample program “UTFT_Demo_480x320.ino” from the utft library works perfectly in the tft “working”. But not in the another.
I´m using the latest version of the UTFT library v2.8.2.
the ILI9486 driver does not work in either. I’m very confused!

Hello, friends!

I have the same problem of Valero. The same LCD don’t work with any library :frowning: >:( Anybody has any library for this LCD? Thank you!

PLEASE HELP!! :confused:

Please post a link to your actual purchase. Compare the link photos with the display on your desk.

Make sure that you check whether it has a row of 7 resistor-packs (like works) or 4 resistor-packs (like the not work in #3)

David.

Hello David, my LCD is identical to the photo attached by Valero with 4 resistor-packs.

TFT LCD

Hello David,
I have this LCD:


This display have only 4 resistor packs and I bought this in my country, I think that the seller bought on AliExpress but I don’t have the link.

I have downloaded your TFT library on Github on this (link) and test with the graphictest_kbv. This firmware shows me by serial port:

Serial took 0ms to start
ID = 0x404

I tried the tft.begin with 0x9481, 0x1581 and 0x7796. But my LCD stay it blank.

Do you any idea what happen with my LCD?

That library is designed for UNO Shields. You have a MEGA Shield with 8-bit parallel inrerface.

You can use my library if you edit files: 1. mcufriend_shield.h: #define USE_SPECIAL 2. mcufriend_special.h: #define USE_MEGA_8BIT_SHIELD

It is not possible to read the ID from your write-only shield. You will just get 0xD3D3. Most of my examples default to ILI9481 if the ID is 0xD3D3. I suspect you have an ILI9486. So you would try 0x9486.

Please say how you get on.

David.

Hello David!

Thank you!! my LCD works! I use 0x9486 but the colors are strange. I have changed by 0x7796 and all is OK. thanks again!

ST7796 is very similar to ILI9488. The only difference is reading GRAM memory.

Since you can’t read a Mega Shield, you would never know!
I suspect you have an ILI9488 just like it says on the tin.

David.