Mega 2560 arrived, cant install drivers

HI all,
I'm on my work machine and have plugged the mega in.

I have tried everything i can find to install the drivers, even redownloaded the arduino software (release 22) as well as the FTDI drivers sepretaly and followed the instructions here:

but no joy. When I plug it in, windows recognises it as a "Arduino Mega 2560" but it is under the "Other devices" node in device manager.

how do i install it so that the arduino programming GUI can see it (currently the serial port menu is greyed out)

thanks in advance


The Mega 2560 doesn't use the FTDI drivers, so you are wasting your time ensuring that they are properly installed and functioning.

i had this the other day, i installed the drivers from arduino 0022. then mine worked

I fixed it, what i was doing was using the wrong folder, i needed to select "drivers" rather than any of the sub-folders and it worked first time :smiley:

yipee! now all i need is a soldering iron and im away!

i did the same fault of choosing sub folders, instd of "drivers".
now im done.