mega 2560 driver digitally unsigned

I'm using windows 7 x64 bit version
I'm trying to connect a mega 2560 board it get recognized but I get a Code52 error (warning) in device manager that the driver used for this device is not digitally signed.
the board is not recognized by the ide.
the board is working on other pc x86

attempts to fix the problem:
un install the ide and boards several times. (still not working)
I read somewhere to install ftdi driver and i did (still not working)
tried to get the .inf form working pc and updating the driver with this file (still not working)

how to fix this issue,
and thanks for help in advance

What do you see in "device manager" under Ports when you plug it into the WORKING pc ?

for the not working:

for the working one, the host is Dell Laptop running Win 8.1 x64:

Go to the drivers folder inside the IDE installation folder and install the drivers

IGNORE the unsigned driver message

I tried to install it from the driver folder, and still it doesn't work.
and the unsigned issue is not a message to ignore, its a warning that shows after the end of driver installation!!

Turn OFF driver signing for that install.