MEGA 2560 not recognized by Arduino IDE

My previously working Arduino Mega had been working fine for the last week or so. Just today I was using it and touched something on my breadboard that was wired to the mega. I shocked it! It worked for a while. Now Windows still recognizes it when I plug it in, but the Arduino IDE doesn't recognize the board. It doesn't see it when assigned to the correct COM port, and if you change the COM port of the board, the Arduino IDE doesn't have the new COM port even as an option under the Tools-Serial Port menu. Was the shock the culprit? If so, how can I check? Or if its another general problem with drivers or something, what needs to be done? Any suggestions are greatly appreciated. Thanks

Was the shock the culprit?

Probably.

If so, how can I check?

http://forum.arduino.cc/index.php?topic=73748.0 ...pass or fail?

Fail...but I must not be doing something right, because I tried it on another computer after it failed, and it was successfully able to upload programs. So it must be just my other PC. But even when I do it on the working PC, it didn't echo back responses. Anyway, thanks for your help.

So it must be just my other PC.

Or a connector in your USB cable. Try a different cable.