Mega 2560 not recognized

While attempting to upload my 2560's first sketch, I received a timeout error (which is addressed in a separate thread, I found). Well, before seeking help, I tried a couple of things like restarting my computer (a Mac). After the first restart, I tried to upload again, but I didn't receive a timeout error. In fact, nothing happened. No feedback, no errors. I opted to restart again, but the Arduino IDE was not responding and I had to force-quit it. After the 2nd restart, the Mega 2560 no longer appeared in the Serial Port menu. Nothing in /dev/ or Network System Preferences to indicate the device was even connected.

Is this thing toast? I'm pretty sure it has to do with the Atmega8U2 because the factory sketch is running fine (pin 13 LED blinking). My only guess is that the force-quit of the Arduino IDE left the usb chip in a bad state.

For what it's worth, I also attempted this on my Windows 7 installation, but it complains about an unknown device, and I'm unable to install the .inf successfully.

Hmm. Try rebooting the computer. Maybe try a different USB cable, too? And / or different USB port on the computer? What do you see in the System Profiler under USB when you connect the board?

Restarting is no good. Tried a new cable, and swapped ports. No luck. Nothing appears in System Profiler when plugging in and Refreshing (cmd+R). I unplugged the mouse and refreshed, and it went away, so I know System Profiler is doing its job.

You should probably contact the distributor you bought the board from and ask about getting a replacement.