Mega 2560 R2 - Powers on, but not detected in Windows

Greetings! My Mega2560 no longer shows up in Device Manager (Win7)... After some reading around, it seemed the most likely issue was that the bootloader was corrupted; I tried using both a USBAsp ICSP programmer and now an Arduino Uno, both to no avail. I followed the guide at ( Gammon Forum : Electronics : Microprocessors : Atmega bootloader programmer ) by connecting the Uno/Mega with breadboard wires, instead of hacking up the 10-pin IDC cable that came with the USBAsp. The Mega2560 now shows a heartbeat-like blinking pattern on the LED, but it is still not detected in Device Manager (whether the reset button is held or not). The Arduino IDE returns a "not in sync" error if I try using "Arduino as ISP" with the sketch from the above link running on the Uno. The sketch has written and verified the bootloader, which is seemingly reflected in the serial monitor from the Uno upon being re-connected afterward:


Atmega chip programmer.
Written by Nick Gammon.
Version 1.21
Compiled on Feb 13 2014 at 01:25:49
Entered programming mode OK.
Signature = 0x1E 0x98 0x01
Processor = ATmega2560
Flash memory size = 262144 bytes.
LFuse = 0xFF
HFuse = 0xD8
EFuse = 0xFD
Lock byte = 0xEF
Clock calibration = 0x81
Bootloader address = 0x3E000
Bootloader length = 7474 bytes.
Type 'V' to verify, or 'G' to program the chip with the bootloader ...
Verifying ...
No errors found.
Done.
Type 'C' when ready to continue with another chip ...

Unfortunately, it is still not being detected in Device Manager or the Arduino IDE. I would really appreciate if anyone can shed any light on this, lest I call it a $60 loss :frowning: --- Thanks in advance!

I guess it's just a lost cause..?