mega 2560 r3 wont load

im new but i have spent 5-6 hours trying to get this thing going.no luck.it powers on .every time i try to load a something it says timed out.please help and thanks

Where did you buy the board? What version of the IDE are you running? Have you tried another cable? What operating system? What serial port are you selecting? What board are you selecting?

Where did you buy the board? ebay
What version of the IDE are you running?1.0.5
Have you tried another cable?yes 2
What operating system?win 7
What serial port are you selecting?com9
What board are you selecting?mega2560
i did the loopback test and it passed
thanks

i have tried 2560 driver and 2560r3 driver no luck

wt43787: Where did you buy the board? ebay

Try contacting eBay's technical support team.

While people here might try to help you, what you bought probably wasn't an Arduino (regardless of what was printed on the board). So it is going to be more difficult to troubleshoot.

If loopback passes either the 2560 is damaged or it doesn't have a boot loader.

thanks james,one more thing it came with blink on it and runs blink ok.the man i got it from thinks it on my end.i think hes going to send me another one.i tried another laptop with vista still no go.is there another interface i can try other than 1.0.5 thanks wt43787

You can use an AVR ISP mkII Programmer and avrdude to read the flash memory. If it works, you can check at address 0x3e000 whether the bootloader is on the chip.