Mega 2560 regulator issue?? [solved]

Hi all,

I have a mega 2560 and ramps 1.4 for a 3d printer. I can control the printer and do everything with it however I can't power the Arduino with out the USB and with the 12v power supply like I used to. Everything works perfectly when the arduino USB is plugged in.

When I use only the 12v supply I get a slightly backlit screen and nothing else. I have done a bit if researching and have checked both D1 and D2 diodes these still both seem to work as they should. I have tried to understand as much as I can and electronics is not my strongest point so the schematic is some what foreign looking.

So I have removed the Ramps board and now I only have the mega 2560 in question

I have connected +12v to the 'VIN' pin and and ground to GND.

I have measured across the 5v regulator and the input pin reads at MINUS 3v. The output pin is reading PLUS 8v. I'm hoping to replace the regulator but the fact that the input is reading -3v makes me think something before the regulator is throwing this??

Thanks in advance for any input, Wes.

Wes296: makes me think something before the regulator is throwing this??

What does the "12V" supply measure when it isn't connected to the Arduino? Ideally with a load (like a resistor).

It's has a load already on it for stable supply and it's gives 11.8v

Between the Vin and input to regulator there isn't anything. So if you are measuring -3V that means:

  1. You aren't measuring it correctly (or not where you think)
  2. The supply isn't working

When you connect your supply, the regulators input to ground should be the same as Vin to ground. From input to output if regulation should be ~7v. Output to ground should be 5v.

Hi,

I hadn't understood the schematic as such I assumed the pins 1,2,3 were input, ground and output respectively. Not ground output input respectively.

It turns out it was a malfunctioning voltage regulator it has been replaced with a standard 7805 until I take delivery of the direct replacement.

Thanks for you help.

Awesome, glad it worked it out.

As you learned, you should never assume that an IC package has a "standard" pin out. Sometimes you might the same part offered in a TO-92 and a surface mount package, but the SMT has a different order of pins than the through-hole. (Even though you might assume it is the same piece of silicon inside.)

Going from a TO-92 to a TO-220 is another example where the pin outs may change.

This is the first time I've used ardiuno and really needed to understand electronics in this way I normally don't push past resistors and LEDs so it's a huge learning curve for myself.

Thank you once again!