MEGA 2560 Serial and ESP8266

I have several ESP8266 modules, when I connect any to my MEGA 2560 Serial 1, of 2 of 3, and try to communicateI do not get theoutput I expect, this is so with all 3 modules:

I send:
Serial3.begin();
Serial3.println(“AT+RST”);
delay(100);
Serial3.println(“AT”)
the blueLED lights up with every communication and baud rate

I read as follows:
while (Serial3.available()) {

  • int inByte = Serial3.read();*
  • Serial.print(char(inByte) );*
  • Serial.print(" DEC: ");*
  • Serial.print(inByte, DEC);*
  • Serial.print(" HEX: ");*
  • Serial.print(inByte, HEX);*
  • Serial.print(" BIN :");*
  • Serial.print(inByte, BIN);*
  • Serial.println();*
  • }*

I get responses from baudrate 57600, nothing with lower speeds:

Baud rate Serial 1: 57600
ÿ DEC: 255 HEX: FF BIN :11111111
ÿ DEC: 255 HEX: FF BIN :11111111
Baud rate Serial 1: 62500
ÿ DEC: 255 HEX: FF BIN :11111111
ÿ DEC: 255 HEX: FF BIN :11111111
Baud rate Serial 1: 76800
ÿ DEC: 255 HEX: FF BIN :11111111
ÿ DEC: 255 HEX: FF BIN :11111111
Baud rate Serial 1: 115200
ÿ DEC: 255 HEX: FF BIN :11111111
ÿ DEC: 255 HEX: FF BIN :11111111
Baud rate Serial 1: 125000
ÿ DEC: 255 HEX: FF BIN :11111111
ÿ DEC: 255 HEX: FF BIN :11111111
Baud rate Serial 1: 153600
ÿ DEC: 255 HEX: FF BIN :11111111
ÿ DEC: 255 HEX: FF BIN :11111111
Baud rate Serial 1: 230400
ù DEC: 249 HEX: F9 BIN :11111001
ù DEC: 249 HEX: F9 BIN :11111001
Baud rate Serial 1: 250000
ñ DEC: 241 HEX: F1 BIN :11110001
ñ DEC: 241 HEX: F1 BIN :11110001
Baud rate Serial 1: 307200
ñ DEC: 241 HEX: F1 BIN :11110001
ñ DEC: 241 HEX: F1 BIN :11110001
Baud rate Serial 1: 500000
Á DEC: 193 HEX: C1 BIN :11000001
Á DEC: 193 HEX: C1 BIN :11000001

I never get anything readable,I at least would expect “OK” at a specific baud settings.

Could this be a MEGA board issue?
Should I update any MEGA firmware?

thanks in advance