Mega 2560 set up

Hi all. New to this.. having some issues setting up the mega 2560. The COM ports in my laptop aren’t recognising the board (I’ve tried showing hidden devices). I’ve tried adding legacy hardware as a COM port and select arduino -> arduino mega 2560, it then adds to COM3 but has a code 10 fault.. I’ve tried updating drivers but it says “The best drivers for your device are already installed.” Any ideas? Thanks

Try another USB-cable.. try plugging it into another computer, see if it reacts that new hardware was connected to the USB-port (i only work with Windows computers, don't (want to) know how it works on other operatingsystems)
If it does not detect any hardware automatically (normally you hear a sound when you plug in something in your USB port, right?) even after changing the cable (some USB-cables are only for charging, with only two wires connected) you have to conclude you have a bad card.


Hi Karl, if its one of the chinese imports you will need to install a driver for the CH340 chip as this is the com port connection. you can get them here: How to Install CH340 Drivers -

Hi there thanks for your reply, ended up being a faulty usb cable! All good now, thanks

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.