mega 2560 stopped working, cant upload

So after a few week of ussing my mega it suddenly stopped working but the green light comes on and the computer does make a sound when i connect it.

when i try to upload it says that the serial port cant be found. Ive ussed it befora and this hapend from one moment to another. Can i do something like resseting it or something...

Post a link to where you got it from, so that the serial to USB can be checked.

Also did the last sketch you uploaded use the serial a lot?

Well i think its a fake one from china (Chip is a 16AU) but i had a uno also from china that worked fine but this one just stoped working.

Exacct scenario: I was playing with my 3d printer... turned the power down. after a few minutes i turned it back again and the controler started beping so i turd it off again. Then i powered it up with my usb cable and i could barely see on the screen but i could go trough the menu so i tried to turn the printer back on again and then nothing.