Mega 2560 stops communicating with computer


I seem to have run into a very frustrating situation. I have had the Arudino for about 2-3 weeks and I work on it every day and I have been learning more and more each day. I have been able to learn and use different shields as well as multiple sensors. However, yesterday, I got a new computer and suddenly my Arduino Mega 2560 Rev 3 can no longer communicate with my new or old computer. I get the following error when I try to upload any code:

avrdude: stk500v2_getsync(): can't communicate with device: resp=0x01

I have looked around the internet at other forums and I have seen people fix this error by installing older drivers or by editing the boards.txt file. However, none of these remedies have worked for me... I have downloaded the 1.5.7 beta arduino folder and tried to use the drivers from that download. I have tried to use the drivers from l.0.5 IDE with no success. Did I miss any other possible solutions? Is there a way I can just download an older driver rather than downloading the entire past IDE folder?

You don't need an older driver. The Arduino IDE 1.6.0 should work. There is a folder "drivers" in the "arduino-1.6.0" folder with "dpinst-....exe", you can use that to install all drivers once more.

Is it an official Arduino board, or a clone ?

Which Windows version are you using ? When you open the Device Manager, is the Arduino Mega visible somehow ?