Mega 2560 Upload "bug" in Windows 7?

Tried to upload a sketch aprox. 13kbyte into Arduino Mega 2560 but it wont upload it.

  • It starts uploading then suddently it stops. No error report! It just stops.
  • Tried on 3 Windows 7 (64bit) machines. Same thing!

The odd thing:

  • I manage to upload my sketch through Mac OS through Virtual Machine from Windows7! doesnt stop here. My program Freezes. It starts ok..but then it freezes. I though this could be a RAM problem as I might use all available RAM. So... i checked this also, through Faludi's program that is available here:

It seems that i have 5k and more available. So i guess its not a RAM issue.

My Question is:

I am in a deadline so must come up with a more efficient solution and rather quick!

So if i buy the Mega 1280 would I encounter such problems? Can anyone tell?

Is there someone available that has an Arduino Mega 1280 who can try out my code, to see if its a 2560 problem?

I can check out your code on a 1280. I use Mac but I will try on Windows as well. I will send you a PM


One thing I noticed. I could not upload to the mega2560 with a xbee board installed. I have not had any problems on a Mac. I have not had a chance to test on Windows yet.


For anyone else reading this thread. jasperssj3 sent me his code and I had no problem compiling, uploading and running it on a 2560 and 1280 on both Mac and Windows XP.