Mega 2560 v3 on Win8 works

I tried all day yesterday and saw a similar problem here, I tried again today and got it, I see another similar problem here now. I know the boot loader was there because the led on the Mega was flashing, I uninstalled the driver and the app, and tried several times. I could not find the .inf file so although my Mega showed up in device manager, it would not load. After trying Arduino 1.5 and the Arduino 1.0.5, i finally saved the Arduino 1.0.5 zip file. Unzipped the sketch ap, connected the Mega, found it in Dev Mgr under Other Devices as Arduino Mega, Right click that, select properties, driver. browse. and under Downloads, arduino, drivers. I did not select hardware, and finish. The driver download worked! For some reason, windows would go to the FTDI_USB file, but using the zip file made everything work. I hope this helps. I have two days of Arduino experience, so a long way to go!

So your topic says it works. Your post doesn't say what doesn't.

Care to clarify?