Mega 2560 with Catalex SD-Card Adapter

Hi Folks,

I already tried to look in the wide collection of knowledge in the internet, but i cant find any solution to my, how i think, exotic problem.

I am trying to run the CardInfo example for the called setup and the only response i get is, the fat16/32 could not be opened. I already formatted the SD-Card with the sd-card formatter tool. I tried several cards with several sizes and still the same result. Just one card didn´t respond at all… On the picture u can see the output of the code example.

The wiring for the Mega should be correct as well.

It would safe my whole week if you could help me out on this issue.

This problem has been solved.

One should be able to read the specs of all the components... Working the SD-Card adapter with just 3.3Volts makes everything fail. By plugging it to the 5V source the magic happened and everything worked out fine.

Thanks for all who even thought about how to solve this problem.

[CLOSE]

it is the only thing that the adaptet does. converting power and logic level. the card itself is the SPI device