MEGA 2560 with CH340 not recognized

Hi,

What can I do with this board ? I can't get it recognized.

Any solutions ?

Here's a picture to the version I have.

COMMON ISSUES

  • Check you have a COMMON GROUND where required.
  • Where possible use USB 2.0 ports or a USB 2.0 POWERED HUB to rule out USB 3.0 issues.
  • Try other computers where possible.
  • Try other USB leads where possible.
  • You may not have the correct driver installed. CH340/341 or CP2102
  • There may be a problem with the board check your wiring first.
  • Remove any items connected to pins 0 and 1.

I did all that.

  1. I don't need a common ground because I'm trying to connect the board, no circuit or other components are connected.
  2. I tried both 2.0 and 3.0 ports.
  3. I haven't tested it on another computer, but I think my gaming rig is pretty powerful to handle this issue.
  4. I tried this driver multiple times and it's actually pre-installed
  5. That could be a possibility, the board could be broken.
  6. Nothing is connected to pin 0 and 1.

I don't know what to do, I put it a side I can't do anything with it right now, I have other uno boards to use.

Some people have reported problems betwen antivirus and driver software so try rule that aspect out. Normally CH340 is not pre installed unless you did it previously. I only trust one source for that driver (link in#1) as there are some nasty versions out there too.

I have tested the driver you provided but the same issue.

Windows shows it with the yellow triangle all the time.

Same problem .. I really started to think it's broken one.

My clone nano got broken right away with one little short between two pins.

I think I would buy the mega that comes with Atmel bootloader chip.

A yellow triangle usually also has an error code ? Usually 10 or 43.

It mostly refers to a driver issue and not a board issue.

Driver issues as already mentioned may be down to other software on the machine. Some other reasons are that the user may not have enough privileges on that machine. This can be especially true if it is not your very own computer or you are using a secure network such as a school or company. Fire walls can also cause the issue.

I would suggest reading the first link below then adding some comprehensive information.

Could you take a few moments to Learn How To Use The Forum. Other general help and troubleshooting advice can be found here. It will help you get the best out of the forum.

|500x422

This is what I get all the time whether I installed a new driver or not.

Have you fully ruled out other software as a cause of blockage ?

To kill a ch340 is quite hard as they are very durable and it would take some severe abuse to break one.

|500x391

I'm trying to use my 24MHz logic anaylzer to detect any signal that explains whether something is broken.

I can only detect VCC and GND signals only, I can't measure any stuff that show me the oscillator signal for example or UART input signal.

Can you tell me if there is a location to measure if the CH340G or the Atmega2560 are broken or not ?

Have never had reason to scope out a ch340 so cannot help on that aspect.

And without that you would have to resort to the ICSP bus

OK I broke my uno board. I know now that the mega board is broken and shorted somewhere.

This week I fried 3 arduino boards :slight_smile: wow

OUCH !

Time to invest in some new glasses ?

OK which chip is fried now ? I can buy some from Aliexpress and solder it later and upload the bootloader.

I think that the mega 16u2 is fried and I can replace it.

In case of the mega2560 maybe the CH340G is fried too and should be replaced.

I don't want to throw the boards out.

The ch340 IIRC does not have a bootloader and is just a serial to usb adaptor. The Mega is a different matter but can be flashed via the ICSP header which is also useful if you fry the USB sides of boards.

You can also use other Arduinos as ICSP programmers.

But now I can't use anything with these faulty boards because the mega2560 fried my uno, so that would really dangerous to try and flash the fried uno with another arduino.

But I can order some new CH340s and try to replace them I have another nano board that fried with a mistaken touch with my screw driver between its legs. So I'm pretty sure now that the CH340s are fried.

As you mentioned that these chips are difficult to burn them but that is what happened with me, the one in the nano board broken in a matter on just the touch, but these clones I guess don't have the premium safety components that is in the original boards.

Anyway I can buy some new CH340s and 16u2 to learn something about fixing arduino boards.

But I have some other esp8266 to play with until I receive my stuff from china.

Yeah .. well I browsed a bit in Aliexpress. I'ts really not worth trying to fix the boards as I also don't have a heat gun to work with SMD parts. But anyway, the Atmega328p of the uno board isn't fried so I guess I can take it out for later use and throw the board.

But the mega2560 is useless now I don't have the tools/components to fix it, it's really better to throw it instead of keeping it.

And of course buy new ones.

It's also an opportunity to try and work with other boards I have like the esp8266, I have 3 of them + miniSTM32 board with arm chip; like this one:

|500x500

And a maple mini with also stm32 chip

|500x333

But I don't know how easy to work with stm32 chips. Can I program them through Arduino IDE ?

yes you can program them via the regular IDE. You just need to install the correct cores for the flavour of STM. In much the same way you would do for ESP's

Yep, I'm trying now to connect the maple mini, there's a good recommendation on youtube for this board :)

I succeeded to connect my maple mini to Arduino.

All I have to do now is trying NOT to fry it as much as I can :grin: