MEGA 2560 won't respond after failed bootloader attempt

Hi! I just updated to the latest arduino IDE version (1.0.4), and I saw in the changelog that the Atmega2560 bootloader was improved. I thought I might give it a go, so I hooked up my USBasp to my mega2560, and hit "burn bootloader". after several minutes the IDE hang, and when I tried to burn the bootloader againg, I'm just getting :

avrdude: error: programm enable: target doesn't answer. 1 avrdude: initialization failed, rc=-1 Double check connections and try again, or use -F to override this check.

I installed CrossPack for mac, and ran this command in terminal: avrdude -c usbasp -P usb -p Atmega2560 -v -v

still I get the same respond, the device is not responding.

I've totally sure that the wireing are correct, I'm using the ISP port. I've also tried with Arduino uno as isp, but no luck.

Is it possible to save my poor mega? Have I fried it?

Do you know what version firmware is on the USBasp?

I think you need at least v1.4 firmware to program parts larger than 128kb

That may explain the issue you are having.

Yeah, my USBasp have firmware v1.02. So, how do I upgrade the formware from a mac? the README file is hard to understand, and I don't own a windows machine.

You will need another ISP programmer first. You could probably use ArduinoISP.

It depends on which type of USBasp programmer you have. You will need to jumper the reset from the 10-pin header to the reset pin on the atmega8. Some have jumper pins for this, some have resister pads (R8) for this, and some don't have the reset broken out at all (but you still could if you have steady hands).

Most of the USBasp have the lock bits set, so you will need to erase the chip first.

All you need is the firmware 2011-05-28 and avrdude to program it. You probably don't need to change any fuses.

I have the jumper 2 broken out, so I can put the USBasp in update mode. I don't have an MKII or TinyISP, so I will have to use ArduinoISP for the job. I will figure out the wiring myself, but which app can I use for updating the USBasp? Like I have mentioned, I'm using a mac. Can I use the arduino software, or do I have to use something else. the thing is that AVRstudio is only for windows, and the WINE-emulator (run windows apps on mac) doesn't support the USB port.

You should be able to use avrdude in the Arduino IDE package.

The following blog entry should help:

After hours of trying to understand how to get it working (found some problems with the wiring) and understaning AVRdude, I finally got mu precious USBasp up to the newest firmware. Since i've "leaned" a bit of avrdude, I hooked up my usbasp to the bricked MEGA2560 and ran this simple command: avrdude -c usbasp -p m2560

still I cant get a response from the atmega2560, and Ive tried with usbasp in arduino software and in command line. I've alo tried this with the arduinoISP sketch, but this is all I get when I tries to verdify the chip.

Reading | ################################################## | 100% 0.06s

avrdude: Device signature = 0x000000 avrdude: Yikes! Invalid device signature. Double check connections and try again, or use -F to override this check.