Mega2560 R3 won't show up on PC but has power

I have an Arduino Mega2560 R3, it was working fine, it was uploading several hours later I went to update the software and it shows the power light and runs the program on there, but it doesnt show up on my computer and therefore wont upload. I even tried to force an install of the driver and it gave me an error code 10 once it was done installing, can anyone shed some light on this?

EDIT: Also, is there a maximum current draw on the 5V supply pin? The 3.3V pin maxes out at 50mA, but there doesn't seam to be anything on the 5V pin...

http://arduino.cc/forum/index.php/topic,113287.0.html

same problem :S

Also I hadn't connected anything new to my Arduino since I went to update my code. I was going to build a parallel programmer for my board but I would like to at least try and figure out what is wrong with the USB portion.

Check your USB cable, some cables not delivered 5 volts and cause the Mega to reset and failed upload with timeout!

To burn a bootloader

and follow the link over. http://arduino.cc/forum/index.php/topic,113680.msg854995.html#msg854995

I tried 3 different cables, all of which I know worked, and also I don't have an UNO.

I saw a post by someone with an UNO or something and it seamed like a similar problem and was talking about putting the chip thats being used as a USB to serial converter into DFU mode and reuploading the firmware to that chip, it seemed to work for him if I remember right, so I was gonna try that. I'll post a link to the post once I find it.

heres the post, its talking about the 8U2, and mine has a 16U2, but I'm sure the concept is the same. --> http://arduino.cc/forum/index.php/topic,59056.0.html

tried using atmels FLIP to reupload the firmware, but it tells me that "address is out of range" when I try to open the HEX file. can I use a parallel programmer and the ISP header to do what I'm trying to do? also how do I know which ISP header pins are which? which pin is pin 1?

If you are using DFU mode to flash the 16u2, you need to use this firmware image: (Do not use the one with "COMBINED" in the name)

hardware\arduino\firmwares\arduino-usbserial\Arduino-usbserial-atmega16u2-Mega2560-Rev3.hex

I’ve tried resetting the 16U2 through the ICSP header, and I left it plugged in to USB, no new hardware shows up and every time I choose the USB option for the communication type [in FLIP] it complains that atlibusbdfu.dll isnt found, I know the dll is there cause I checked. Any help?

EDIT: Also whats the difference between the combined and the firmware your talking about?

There are two firmwares loaded on the 8U2/16U2 DFU bootloader and USB Serial firmware

The COMBINED hex is meant to be loaded via the ICSP header and will program both the bootloader and USB Serial firmware.

The Arduino-usbserial-atmega16u2-Mega2560-Rev3.hex is only the USB Serial firmware and is meant to be loaded by the DFU bootloader when in DFU mode.

oh ok, I can't get anything to show up though, nothing shows up when I plug in My mega to be programmed, but the last sketch I uploaded is still on there and I know its still working, so I was gonna try flashing the 16u2 to try and fix the communication problem, but I haven't been able to get anything to show up, and flip is telling me that atlibusbdfu.dll is missing [again, I know its there, but flips being retarded obviously], if I can get flip working that would be great

Well I finally got my parallel programmer built, and I used the following command to try and flash my 16u2

C:\arduino\arduino-1.0.1\hardware\tools\avr\bin>avrdude -C ../etc/avrdude.conf -
p m16u2 -F -c dapa -U flash:w:../../../arduino/firmwares/Arduino-COMBINED-dfu-us
bserial-atmega16u2-Mega2560-Rev3.hex -U lfuse:w:0xFF:m -U hfuse:w:0xD9:m -U efus
e:w:0xF4:m -U lock:w:0x0F:m -v

but I get this...

C:\arduino\arduino-1.0.1\hardware\tools\avr\bin>avrdude -C ../etc/avrdude.conf -
p m16u2 -F -c dapa -U flash:w:../../../arduino/firmwares/Arduino-COMBINED-dfu-us
bserial-atmega16u2-Mega2560-Rev3.hex -U lfuse:w:0xFF:m -U hfuse:w:0xD9:m -U efus
e:w:0xF4:m -U lock:w:0x0F:m -v

avrdude: Version 5.11, compiled on Sep  2 2011 at 19:38:36
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
         Copyright (c) 2007-2009 Joerg Wunsch

         System wide configuration file is "../etc/avrdude.conf"

         Using Port                    : lpt1
         Using Programmer              : dapa
         AVR Part                      : ATmega16U2
         Chip Erase delay              : 9000 us
         PAGEL                         : PD7
         BS2                           : PC6
         RESET disposition             : possible i/o
         RETRY pulse                   : SCK
         serial program mode           : yes
         parallel program mode         : yes
         Timeout                       : 200
         StabDelay                     : 100
         CmdexeDelay                   : 25
         SyncLoops                     : 32
         ByteDelay                     : 0
         PollIndex                     : 3
         PollValue                     : 0x53
         Memory Detail                 :

                                  Block Poll               Page
      Polled
           Memory Type Mode Delay Size  Indx Paged  Size   Size #Pages MinW  Max
W   ReadBack
           ----------- ---- ----- ----- ---- ------ ------ ---- ------ ----- ---
-- ---------
           eeprom        65    20     4    0 no        512    4    128  9000  90
00 0x00 0x00
           flash         65     6   128    0 yes     16384  128    128  4500  45
00 0x00 0x00
           lfuse          0     0     0    0 no          1    0      0  9000  90
00 0x00 0x00
           hfuse          0     0     0    0 no          1    0      0  9000  90
00 0x00 0x00
           efuse          0     0     0    0 no          1    0      0  9000  90
00 0x00 0x00
           lock           0     0     0    0 no          1    0      0  9000  90
00 0x00 0x00
           calibration    0     0     0    0 no          1    0      0     0
 0 0x00 0x00
           signature      0     0     0    0 no          3    0      0     0
 0 0x00 0x00

         Programmer Type : PPI
         Description     : Direct AVR Parallel Access cable
           VCC     = 3
           BUFF    =  (not used)
           RESET   = 16
           SCK     = 1
           MOSI    = 2
           MISO    = 11
           ERR LED = 0
           RDY LED = 0
           PGM LED = 0
           VFY LED = 0

avrdude: AVR device not responding
avrdude: initialization failed, rc=-1
avrdude: AVR device initialized and ready to accept instructions
avrdude: Device signature = 0x000000
avrdude: Yikes!  Invalid device signature.
avrdude: Expected signature for ATmega16U2 is 1E 94 89
avrdude: NOTE: FLASH memory has been specified, an erase cycle will be performed

         To disable this feature, specify the -D option.

avrdude done.  Thank you.


C:\arduino\arduino-1.0.1\hardware\tools\avr\bin>

Anyone got any ideas on whats going wrong?

EDIT: also, is there a way to use a parallel programmer with FLIP?