Mehrere DS18B20

Hallo

Ich habe mir einen Logger mit 9 DS18b20 Sensoren zusammengebaut und er scheint eigentlich auch zu funktionieren. Als ich mir die aufgezeichneten Daten ansah, hat sich ein Bild gezeigt, wie wenn zwischendurch mal die Daten von einem Sensor dem nächsten zugeordnet worden wäre. (vgl. Bild )

Hat jemand eine Ahnung woran das liegen könnte?

Die Sensoren sind parallel angeschlossen und ein 4.7kOhm Widerstand von 5V zu Data.

Kann meiner Meinung nach nur an deinem Programm liegen :slight_smile: Das hast du aber nicht vorgestellt.
Die Sensoren liefern ihre Daten immer nur wenn sie mit ihrer Seriennummer angesprochen werden. Falls also was durcheinander kommt, kann es nur an der abfragenden Software liegen

Bitte zeig uns deinen Sketch, dann können wir dir sicher Tipps geben. Poste den Sketch bitte in Code-Tags, damit wir den besser lesen können.

Nun scheint der Logger so zu funktionieren wie er soll, aber ich kann nicht sagen woran es lag, aber die Temperaturkurven sehen nun gut aus.

kann es sein dass das etwas mit dem folgenden Hinweis beim Kompilieren zu tun hat?

"Wenig Arbeitsspeicher verfügbar, es können Stabilitätsprobleme auftreten."

ich glaube der Sketch bringt nun wenig, das es ja nun funktioniert.

Hallo,

was haste denn geändert das es jetzt plötzlich angeblich funktioniert? Wenn der RAM zu klein wird kommt es zu den tollsten Effekten. Wer den Code geheim hält....

Ok, wenn er geheim ist.

Aber so könnten wir ihn testen und evtl. den Fehler finden. Speicherprobleme sind immer kritisch, aber ohne Sketch kein Tipp.