Mensaje de Error: Espúrias

Antes de empezar con mi proyecto me encuentro con un problema que no me deja continuar.
Este es el código:

#include <SPI.h>
#include <Adafruit_WINC1500.h>
#include <Adafruit_GPS.h>
#include <SoftwareSerial.h>

void setup() {
  // put your setup code here, to run once:

}

void loop() {
  // put your main code here, to run repeatedly:

}

y al verificar este código el compilador me arroja este mensaje:

ATENCIÓN:  .github Espúrias carpetas en librería 'Adafruit_WINC1500'
libraries/SoftwareSerial/SoftwareSerial.cpp.o (symbol from plugin): In function `SoftwareSerial::read()':
(.text+0x0): multiple definition of `__vector_3'
libraries/Adafruit_WINC1500-master/bsp/source/nm_bsp_arduino_avr.c.o (symbol from plugin):(.text+0x0): first defined here
libraries/SoftwareSerial/SoftwareSerial.cpp.o (symbol from plugin): In function `SoftwareSerial::read()':
(.text+0x0): multiple definition of `__vector_5'
libraries/Adafruit_WINC1500-master/bsp/source/nm_bsp_arduino_avr.c.o (symbol from plugin):(.text+0x0): first defined here
libraries/SoftwareSerial/SoftwareSerial.cpp.o (symbol from plugin): In function `SoftwareSerial::read()':
(.text+0x0): multiple definition of `__vector_4'
libraries/Adafruit_WINC1500-master/bsp/source/nm_bsp_arduino_avr.c.o (symbol from plugin):(.text+0x0): first defined here
collect2: error: ld returned 1 exit status
exit status 1

Alguno de vosotros ha tenido este problema?
Que puedo hacer?

He cambiado de version el Sketch, he actualizado librerías … pero sigo estancado en el mismo punto.

Alguna idea o solución?

Gracias a to2

Posible solución Adafruit forum

Gracias surbyte pero ese post lo puse en el foro de Adafruit y tras hacer lo que me dijeron en la primera respuesta sigo esperando contestación al resto. Ninguno tiene una idea de cómo evitar este problema? Gracias por la ayuda.

Si Adafruit no te responde, yo cambiaría de librería si la hubiera. como tu modulo es de ellos, insiste. Yo se que el problema tiene que ver con la asignación de interrupciones asignadaas a los pines, asi que por ahi viene el problema, mas aun si usas SoftwareSerial que basicamente eso hace con el PIN asignado a recepcion.

una consulta que hice a adafruit sobre una placa me respondieron en menos de dos dias, pero ahora igual es época de vacaciones (en españa, en agosto se paraliza el pais) y por eso tardan más