Mi Mac y mis módulos Bluetooth se "cansan unos de otros"

Buenas tardes foreros de Arduino, "cansarse unos de otros" no es el término más científico, supongo que será algún problema de permisos / ficheros / puertos... derivado de enlazar y desenlazar pero no se qué hacer.

Explicaré un poco la situación. Estoy con una Arduino UNO y dos módulos HC-05 GW-040 en un Mac Pro del 2008 con Yosemite. Los tengo los dos configurados, entrando en modo AT mini y todo eso sin problemas (ahora, porque llegar a ello me ha costado lo suyo).

El caso es que durante todo el proceso de configuración, carga de programas, pruebas... hay una constante que es enlazar el módulo con el mac para probarlo a través del puerto Serial de Arduino y desenlazarlo a los pocos minutos para cargar un programa nuevo. Y vuelta a empezar, así todo el rato, sobre todo al principio que me han liado bastante la cabeza y sólo cambiaba algún detalle de una línea de código entre prueba y prueba.

El caso es que mi querido mac al cabo de un rato se "cansa" del módulo y se niega a enlazar con él. Al principio me volvía loca, ahora he descubierto que con los dos módulos a mano, cambio al otro y listo, cuando mi mac se "aburra" de él, cojo de nuevo el primero. En lo que he estado con el alternativo trabajando el problema ya se ha resuelto, por eso sospecho de puertos, permisos o cosas de esas, pero no se qué puede ser exactamente.

¿Estúpido verdad? Ahora me sirve porque tengo los dos a mano, pero me gustaría saber cual es la causa de esto.

El error que me da el mac es sólo "Error de conexión" en el panel de preferencias de Bluetooth.

No adjunto código porque esta situación es independiente de cuál esté cargando.

Alguna ayuda, idea al respecto, ¿algo? Gracias de "antebraso"

Y porque no armas un Windows 7 virtual y te olvidas del problema. Tengo amigos que tienen MAC que hacen eso.

Hola surbyte

Pues 1) Tengo un MAC, un MAC. No voy a virtualizar windows para programar en Arduino cuando se programa perfectamente en mac. Mac mola, windows caca. (entendamos esto en tono de chiste por favor, no pretendo ser borde ni extremista)

  1. Virtualizar Windows ante este problema es huir de él, no resolverlo

  2. Abrí las máquinas virtuales por primera vez en dos años hace una semana, porque quiero flashear un móvil con el Odin... pues vaaaaaan leeeeenntiiiiisiiiiimaaaaaaas. Estoy actualizando todo el software e intentando resolver el problema, pero básicamente no es nada viable virtualizar ahora mismo

Perdona mi interrupción.

Entonces usa LINUX!!!, No?
Les tengo manía a los que usan MAC, ustedes se creen que es sistema perfecto. Bien.
Creo que es una consulta con sistemas operativos, nada que ver con Arduino, verdad?

:slight_smile:

Yo tengo MAC y no me da esos problemas, prueba a actualizar a la última versión de OS X EL CAPITAN